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GIS MODULE 2

QGIS BASICS I: INTERFACE



LEARNING OBJECTIVES

In this module, you will learn:

● The QGIS interface, including basic tools and menu options

● How to download TIGER data from the US Census website

● How to add TIGER vector data to a map

● How to explore a data attribute table

● How to save a map file.

● Time Required: 15-20 minutes with self-paced learning breaks and 
download time.



PART ONE - QGIS INTERFACE



OPEN QGIS 

● In Module 1 you installed QGIS. Look for 
the QGIS Desktop icon on your Desktop 
or in your downloads folder. Double 
click on it to open. 

● It will take a moment or two to load 
depending on your computer. A tip 
screen will appear each time you start 
the program that may provide helpful 
information as you learn the program.

● Close the tip screen. NOTE: It can be 
turned on/off under Settings > Options > 
General. 

● Use the open QGIS program to explore 
as you go through the next 8 slides.



QGIS INTERFACE

1. MENU BAR
2. TOOLBARS
3. BROWSER PANEL
4. LAYER PANEL 
5. MAP CANVAS
6. STATUS BAR
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1 - MENU BAR

● Provides access to various QGIS features using a standard 
hierarchical menu. Hover or click on each menu item to explore.

● The top-level menus and a summary of some of the menu options 
are listed below

● Note: QGIS is a cross-platform application. The same tools may be in 
different menus depending upon the operating system specification. 

● For additional information about tools and toolbars, see 
documentation section Toolbars.

https://docs.qgis.org/2.18/en/docs/user_manual/introduction/qgis_gui.html#label-toolbars


2 - TOOLBARS

● Toolbars provide quick access to many of the same functions as the 
menus and additional map interaction tools. 

● Hover your cursor over the toolbar icon to display a short 
description of the tool’s purpose. 

● TIP: Hover over the vertical line to find out what                         
toolbar you are viewing.

● Customize your Interface via the Settings ‣ Toolbars menu. Toolbars 
can be reorganized, added, or switched off. If they are not visible in 
a toolbar, all tools remain accessible via the Menu. 

● TIP: If you hide a toolbar, you can restore it by choosing Menu --> 
View > Toolbars.



3 - BROWSER PANEL

Panels are special widgets that you can interact with when performing 
advanced tasks.

The Browser panel lets you navigate in your database, and access 
common vector files (e.g. ESRI shapefile), databases (e.g.PostGIS,  
Spatialite) and WMS/WFS connections, and view GRASS data.

ACTION: We will not be using 
the Browser Panel in these 
modules. Please close it 
using the ‘x’ in the corner!



4 - LAYERS PANEL & LAYER TOOLS

The Layer Panel provides a list of all the 
layers added to the map.

The layer tools allow you to add 
different types of geospatial data to the 
map.

The map canvas displays the layers in 
the order in which they are listed in the 
Layers Panel. Drag and drop to reorder.

LAYER TOOLS



This window displays a map that will depend on the vector and raster 
layers you have chosen to load (listed in the Layer Panel).

MAP NAVIGATION TOOLBAR: Using the toolbar to navigate the map.

MOUSE WHEEL: Place the cursor inside the map area and roll the 
wheel away from you to zoom in and towards you to zoom out. The 
zoom is centered on the mouse cursor position. Pan by moving the 
mouse while holding down space bar or the click button on mouse 
wheel. Customize settings in Settings ‣ Options > Map Tools Menu.

ARROW KEYS - PAN: With the cursor inside the map canvas, press the 
right arrow key to pan east, left arrow key to pan west, up arrow key to 
pan north and down arrow key to pan south. 

5 - MAP VIEW / MAP CANVAS



6 - STATUS BAR - LEFT SIDE

On start up, shows the 
availability of new or 
upgradeable plugins.

During mapping - a 
summary of actions 
you’ve done (such as 
selecting features in a 
layer, removing layer) 
or a long description 
of the tool you are 
hovering over (not 
available for all tools).

The current position of 
the mouse, following it 
while moving across 
the map view. Set the 
unit in Project 
Properties, General tab. 

The small button at the 
right of the box toggles 
between the 
Coordinate option and 
the Extents option that 
displays in map units.

The scale of the map 
view. Zoom in or out 
and see the current 
scale. There is a scale 
selector, which allows 
you to choose among 
predefined or custom 
scales to assign to the 
map view.

The lock allows you to 
lock the scale to use 
the magnifier (next 
slide).



6 - STATUS BAR - RIGHT SIDE

Shows the current 
Coordinate Reference 
System (CRS). Click on 
this to open the CRS 

Project Properties 
dialog box. 

Messages button 
opens the Log 

Messages Panel which 
informs you on any 
underlying process 

(QGIS startup, plugins 
loading, etc)

Define a magnification 
level (expressed as a %) 
for your map view. Zoom 
in to a map without 
altering the map scale. 
For example, at 100%, the 
current map is not 
magnified. 

Define a default value in 
Settings ‣ Options ‣ 
Rendering ‣ Rendering 
Behaviour. 

Define a current 
clockwise rotation 
for your map view 

in degrees.

Use the checkbox 
to temporarily 
prevent layers 

being rendered, or 
drawn, in the map 

view.



STOP & EXPLORE

● Take a few minutes to explore the different components of the QGIS 
Interface. 

● Try to identify the following six tools and their functions on your own 
screen. You will become more familiar with these tools as you use 
them in the upcoming modules.



PART TWO - ADD DATA TO A MAP



UNZIP CENSUS TIGER DATA

● Open your ‘Census Data’ folder on your desktop.              
Unzip the 3 files you previously downloaded - 
tl_2017_12_prisecroads.zip, tl_2017_12_places.zip, 
tl_2017_us_state.zip. 

● For more support in how to unzip a file in Windows, 
Mac OS, or Linux.

● QGIS should be open,but if not reopen QGIS by 
double clicking the icon

● Start a new project 

In Module 1 you downloaded TIGER data from the US Census website. 
You will now explore these data layers in a map.

https://support.microsoft.com/en-us/help/14200/windows-compress-uncompress-zip-files
http://www.winzip.com/mac/en/zip-for-mac.html
https://askubuntu.com/questions/86849/how-to-unzip-a-zip-file-from-the-terminal


PROJECTING THE DATA

When you add a layer in a new project, 
QGIS automatically looks for its 
Coordinate Reference System (CRS) and 
zooms to its extent. 

NOTE: The CRS of the first layer added to 
the map is applied to your entire project. If 
you add a new layer in a different CRS 
from the first layer you must enable 
on-the-fly CRS transformation to help them 
fit together on the map. 

We will do this now.

For more about projections and CRS, see 
https://www.youtube.com/watch?v=kIID5FDi2JQ 

Map Projections - Used to portray the 
surface of the earth or a portion of the 
earth on a flat piece of paper or computer 
screen. All map projections necessarily 
distort the surface in some fashion. 

Coordinate Reference System (CRS) - 
Used to define, with the help of 
coordinates, how the two-dimensional, 
projected map in your GIS is related to 
real places on the earth. 

The map projection and coordinate 
reference system to use depends on the 
regional extent of your map area, your 
intended analysis and often the 
availability of data. For example, if you are 
mapping Maine you will use a different 
CRS than if you are mapping Argentina.

https://www.youtube.com/watch?v=kIID5FDi2JQ


TRANSFORM CRS - ENABLE ‘ON THE FLY’ 

● Navigate to Project ‣ Project 
Properties ‣ CRS OR click EPSG on 
the status bar

● Click the box ‘Enable ‘on the fly’ 
CRS transformation (OTF)

● Click ‘Apply’ & Click ‘Ok’

● When you add new data layers, 
they will now project automatically.



ADD VECTOR DATA - UNITED STATES

● Click on the ‘Add Vector Data’ button.          

If you are unsure of the button, hover 

over each button to see the function.

● Click ‘Browse’

● Navigate to your ‘Census Data’ folder 

on the desktop.

● Double click on the tl_2017_us_state 

folder. One file should be visible. If not, 

make sure that the file type is set to 

‘ESRI Shapefiles’

● Click ‘Open’



ADD VECTOR DATA - UNITED STATES

● You will return to the original 

screen, and the Source 

window should now have the 

dataset name. 

● Click ‘Open’

● Your map view should now 

show a map of the United 

States. The Layers Panel 

should show the 

tl_2017_us_state vector layer.



ADD VECTOR DATA - ROADS

● Click on the ‘Add Vector Data’ button.          

If you are unsure of the button, hover 

over each button to see the function.

● Click ‘Browse’

● Navigate to your ‘Census Data’ folder.

● Double click on the 

tl_2017_12_prisecroads folder. One file 

should be visible. If not, make sure that 

the file type is set to ‘ESRI Shapefiles’

● Click ‘Open’



ADD VECTOR DATA - ROADS

● You will return to the original 

screen, and the Source 

window should now have the 

dataset name. 

● Click ‘Open’

● Your map view will be visible 

on top of a map of the United 

States. The Layers Panel will 

display the 

tl_2017_12_prisecroads and 

the tl_2017_us_state layer.



ADD VECTOR DATA - PLACES

● Click on the ‘Add Vector Data’ button.          

If you are unsure of the button, hover 

over each button to see the function.

● Click ‘Browse’

● Navigate to your ‘Census Data’ folder.

● Double click on the tl_2017_12_place 

folder. One file should be visible. If not, 

make sure that the file type is set to 

‘ESRI Shapefiles’

● Click ‘Open’



ADD VECTOR DATA - PLACES

● You will return to the original 
screen, and the Source window 
should now have the dataset 
name. Click ‘Open’

● Your map view will be visible on 
top of a map of the United 
States. The Layers Panel will 
display the tl_2017_12_places 
tl_2017_12_prisecroads and the 
tl_2017_us_state layers.

● Drag and drop to reorder the 
layers within the Layers Panel. 
They will appear in the canvas as 
listed in the Panel. 



INVESTIGATE THE DATA - IDENTIFY TOOL

● Zoom into the continental USA by 
using the zoom tool        and drag 
to select the continental US.

● With the state file highlighted in 
the Layer Panel, click the         
‘Identify Features’ tool. 

● Click on what looks like Texas. 
The state will be outlined in red, 
and a information box will open, 
displaying the attributes of the 
chosen state, or feature.

● Take a minute to explore the US. 
● Click in the white space around 

the US to unselect.



ZOOM TO LAYER

1. Use your mouse wheel and scroll forward 
zoom into Florida

2. Use the zoom tool        to select and zoom 
into Florida

3. Right click on ‘tl_2017_12_prisecroads’ in 
the Layers Panel. Choose the first option ‘ 
Zoom to Layer’. Because this is a 
Florida-only road layer, it will zoom to that 
extent.

4. Highlight ‘tl_2017_12_prisecroads’ in the 
Layers Panel. Go View > Zoom to Layer in 
the Menu bar.

5. Florida will appear in your Map Canvas.

Let’s zoom into Florida! There are 4 different ways to do this:



INVESTIGATE THE DATA - ATTRIBUTE TABLE

● Open the Attribute Table by right clicking 
on tl_2017_us_state then clicking on Open 
Attribute Table OR highlight the layer in the 
Layer Panel and Click

● Take time to explore.

Attribute tables contain the data related to each feature, and are a 
fundamental part of a GIS.

Shows total number of 
features. Here, US states 
and territories

Each row 
represents a 
feature. In this 
case, a state



SAVE THE MAP PROJECT

● To save your map, Click       OR on the Menu Bar go to ‘Project’ > 
‘Save As’ - and a save window will open. 

● Navigate to your Census folder. Name the project ‘Florida Places’ 
and Click ‘Save’

● The project name should now be at the top of your program window

In the next Module, you will learn how to style these layers and 
compose a printed map. 

Please keep QGIS open if you are continuing to Module 3.



NEXT IN THE PATH - 
GIS MODULE 3

QGIS BASICS II: DESIGN A MAP


