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Data Entry User's Guide

Introduction to Data Entry

The Data Entry module allows you to enter data into one or more data files. It uses a previously developed data entry
application to control the data entry process.

This guide contains the following information:
Data Entry Concepts

e Modes of Operation

e Casesand Levels

e Trees

e Forms
e Fields

e Repeating Groups of Fields

e Persistent Fields

e Field Colors

How to...

e Open an Application

e Begin Adding Cases

e Begin Modifying Cases

e Begin Verifying Cases

e Stop Data Entry

e Pause Data Entry

e View Operator Statistics

e Adda Note

e Change View

e Get Help

e Types of Files

e |Index File (.csidx)

e Listing File (.Ist

e Notes File (.csnot)

e Operator Statistics File (.log)

e Status File (.sts)
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Summaries

e Menu

e Toolbar

e Keys
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Data Entry Concepts

Modes of Operation

There are five different modes or states of operation within CSEntry. They are as follows:

Mode Description
Add Enter new cases.

Modify Modify previously entered cases.
Verify Verify previously entered cases.

Pause Temporarily stop adding, modifying, or verifying cases. The timer maintained for statistics collection is
suspended. Pause is used when you plan to continue from where you left off after a short delay.

Stop Not adding, modifying, or verifying cases in the data file. No form is visible.

Cases and Levels

A case is the primary unit of data in the data file. A case usually corresponds to a questionnaire.

Some complex applications have a hierarchical set of questionnaires. For example, the main questionnaire may consist of a
household roster and other household information, and there may be a separate questionnaire for each woman in the
household. The data entry application may then contain two levels: one for the household and one for each woman in the
household. The set of forms corresponding to the household make up level one. The set of forms corresponding to each
woman make up level two. Each case would consist of a level one and a variable number of level occurrences for level two.
Most applications consist of a single level.

Trees

There are two trees on the left side of the screen: the file tree and the case tree.

File Tree

The file tree shows all cases in the data file. In a single level application, the tree shows the complete IDs for each case. The
icons in front of the IDs indicate whether the case is complete or partial. For example the tree might look like:

File ]

e 010103000110210241
~.[_] 010117100110870031

[ 010117100121120281

~.[_] 010107500210560041

.[_] 010108800220740201

In the tree above, the first case has been partially verified, the third case has been partially modified, and the last case has
been partially added.

In a multi-level application, the tree shows the level occurrences for each case. In the following example there are two
levels.
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File |

E||:| 010101001001

; c 0ol
L@ 002

SR I] 010101001005

Casesin a data entry data file are indexed by their level one ID fields. You cannot have two cases with the same level one IDs
in the same data file. Within cases, level occurrence IDs must also be unique, but within the file they may repeat.

Case Tree

When adding, modifying, or verifying individual cases, a second tree, called a case tree, may be active if this feature was
selected during development of the data entry application. The case tree shows the internal structure of the active case.
The case does not occur when data entry is stopped. The following is an example of a case tree:

File Case
=& 010115600510930081
-1 BOOK
.0 FQUEST
- PROVINCE = 1
- DISTRICT =z 1
- VILLAGE., 158
mmFERL...... 5
mmUE...... 1
----- mm BOTILDTNG 93
..... = HT...... g
----- mm HH......
E-—1 FERSONO00 : 3 cceocurrences
2" (1)
----- B LIHE. . .uuuss- 1
----- mm P02 REL...... : 1
----- mm P03 _SEX...... 2
----- mm P04 AGE...... 548
----- B FOS M5....... 4
----- —1 P06 _MOTHER. .. 2

In the tree above, the current value is displayed to the right of each data field. Some tree elements, such as BOOK and
PERSONOOQO have no values beside them because they represent forms and rosters, respectively.

Forms

A form appears on the screen when you Add, Modify, or Verify cases. A form contains data fields and text. Forms may be
larger than the actual screen area. The form will scroll automatically to insure that the field you are entering is visible on the
screen.

Data entry applications may consist of several forms. As you complete one form the next form is presented. If you move
backward from the first field on a form, the previous form is presented.

Fields

A field is the basic element on a data entry form into which you enter data. During data entry the cursor moves from one
field to the next, according to the order and rules defined by the data entry application. Fields are shown on the form as
boxes with tick marks to indicate how many digits or characters may be keyed.
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Some fields cannot be entered. They may contain either data previously entered on another form or protected fields. Such
fields appear dark gray in color.

Repeating Groups of Fields

A multiple group is a set of fields that repeats more than once. There are two kinds of multiple groups: roster and repeating
forms.

Rosters

Line number| Relationship| Sex| Age

1 (L] O H
2l [, ] NNy
3) (L] L O]

The default roster orientation is horizontal, which will show individual fields across the column headings. Each row of the
roster therefore corresponds to an occurrence of this group. The group repeats as many times as there are lines. In the
example above, the group contains four fields and three occurrences.

Navigation through the group is as follows (for operator-controlled applications):

e Use the / (slash) key on the numeric keypad to jump to the next occurrence.

e Use the Ctrl+/ key to jump out of the roster entirely.

Repeating Forms

Sometimes the same blank form will appear for you to complete. In this case, the form itself corresponds to a group
occurrence, rather than a roster. Navigation keys (/, Ctrl+/, etc.) will be identical as in the roster because only the
presentation of the information is different.

Persistent Fields

The application designer may define ID fields to be persistent. This usually occurs when the designer does not anticipate the
IDs changing between cases within the data file, such as for geographic IDs. The operator will enter values for the first case,
and then the system will use those values for the IDs of subsequent cases.

However, if the operator needs to change an ID, they can do so by successive presses of the F7 key, which will back the
operator up through the ID fields.

Persistent fields are shown as light gray boxes on the form.

Field Colors

CSEntry uses colors to indicate the status of each field.

White

System-controlled: You have never passed through this field for data entry input or you have passed through this field for
data entry input, but have moved backwards over it.
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Operator-controlled: You have never moved this far forward during data entry of this case.
Green

System-controlled: You have passed through this field for data entry input and have not moved backwards over it. If you
move backwards over green fields, they become white.

Operator-controlled: You have passed through this field for data entry input and have not moved backwards over it. If you
move backwards over green fields, they become yellow.

Yellow

System-controlled: This color never occurs.

Operator-controlled: You have passed through this field for data entry input and have moved backwards over it or you have
skipped over this field during data entry. Green and yellow shows you the "high-water mark," that is, how far forward you
have reached in this case.

Gray

Both: You cannot enter the field. The field either contains a previously entered value from another form or is a protected
field.

Light Gray
Both: The field takes on the value from the previous case. You can change the value by using the F7 key to back up into it.
Example

In the following operator-controlled example, Province and District are persistent, which means that their values were
carried over from the previous case. The operator keyed HH No. through CY Income, then backed up to Line number. The PY
Income field is protected and has been filled in via logic in the program.

Province
District
HH no.

Line number

CY Income PY Income

5| | 1 1 Illﬂlﬂ
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How to ...

Open Applications and Data

Files

Open an Application

1. Press Ctrl+O; or from the File menu, select Open Application; or click k= on the toolbar.

2. Select from the Files of type: at the bottom of the dialog box. You can open either a data entry application file (.ent)

or a Program Information file (.pff).
3. If you opened a data entry application file, you will be requested to select the name of the data file(s).

4. Enter the Operator ID (if required).
If you already have another application open, it will be closed.
CSEntry also accepts a single command-line parameter. It may be one of the two following types:

e .ent: Thisis a data entry application file. CSEntry will prompt for the data file(s).

o .pff: CSEntry will open both the application and the data file(s).
In either case, you must specify the full filename. For example:

"C:\Program Files (x86)\CSPro 7.3\CSEntry.exe" MySurvey.pff
"C:\Program Files (x86)\CSPro 7.3\CSEntry.exe" "Census Application.ent”

Open a Data File

If an application has been opened, you may open a data file as follows:

']
1. Press Ctrl+D; or from the File menu, select Open Data File; or click L= on the toolbar.
2. Select the data file that you want to open. If you want to create a new data file, enter a new name.
3. Press Open.

4. Enter your operator ID (if required).
Notes

e You can create a new data file simply by typing in a new name.

e You can only work on one data file at a time. If you open a new data file, the previous one will be closed.

o No default extension is provided in CSEntry, therefore, if you want a certain extension, you must type it.
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e CSEntry uses the operator ID in the operator statistics, which are kept in the log file.
e The operator ID may be up to 32 characters long and may include any character, including embedded spaces.

e Some applications do not require you to enter the operator ID.

See also: Types of Files

Define File Associations

Most data entry applications read and write data only to the primary data file. However, some applications use more files.
For example, there may be one or more external lookup files. In addition, usage of the write commands require file
associations to be supplied.

You may see the "Define File Associations" dialog box but what is being asked of you may vary. The following shows the order
in which files will be solicited from you, and why:

Input Data File
This is the file you will be creating, modifying, or verifying.
External File (dictionary name)

For each lookup file your application uses, you must supply the data file to which the lookup dictionary refers. CSEntry will not
allow you to run your application without naming this file. The name in parenthesis is the unique (internal) dictionary name.
A separate entry will be given for each lookup file attached to your application.

Write File

If your program includes one or more write functions, CSEntry will ask you for the file to write them all to. If you fail to name
a file, all write function text will be placed in the listing file.
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Add Cases

Begin Adding Cases

Press Ctrl+A; or from the Mode menu, select Add; or cIickE«:. on the toolbar to begin adding cases at the end of the data
file.

This will begin a new Add mode session. You may add as many cases as you like. To end the session, press Esc or Ctrl+S.
Depending on where you are in the case and if the partial feature is allowed will determine what will happen next.

¢ [fyou have not yet begun keying a new case: pressing Esc or Ctrl+S will exit the add mode.

¢ |f you have begun keying a new case, but have not finished keying the IDs for that case: pressing Esc or Ctrl+S will
present you with a dialog, asking if you want to discard the changes you have made, or cancel the stop request
(which will return you to your form where you left off).

e [fyou have begun keying a new case and have finished keying the IDs for that case, and partial cases are allowed,
the partial save button will be active. Selecting it will save the case and indicate it is partially saved from add mode by

the icon * in the file tree.

Save Partially Added Case

In order to save a partially created case, two conditions must be met.

The most important condition is that during development of the data entry application, the partial feature must have been
selected. During keying if you attempt to exit from your case, the Partial Save button will appear on the Stop Adding dialog
box.

The second condition is that you must have finished entering the IDs for that case. If you have, the Partial Save button will

be enabled on the Stop Adding dialog box. Choosing it will save the case, remembering the field your cursor was last on and
returning you to this field when add is resumed.

Complete Partially Added Cases

Partially added cases are marked with # in the File Tree. Pressing Ctrl+B toggles the tree between showing all the cases, or
only the partially completed cases.

Toreload a partially added case, select it in the File Tree and press Enter, or double-click the case with the mouse.

You will be asked whether you want to return to the field where you left off, or start at the beginning of the case.

Enter Data

When you begin entering data in a new file, CSEntry will automatically show the first requiring data entry.
When entering decimal numbers, you must always key a decimal character to move to the decimal part of the entry.

After entering data for each field, you may be required to press Enter, depending on your application's runtime settings.
Otherwise, the cursor will automatically move to the next field once the current field is completely filled. If for a given data
field two digits can be entered, and the operator enters 02, the system will automatically advance to the next field (if the
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application has been designed to do this). If, however, the operator only entered 2 for this field, then the operator would
have to press the Enter key to advance to the next field. In any case, you can press Enter to move to the next field if the
current field is not filled up.

Your application may have been designed with skip logic. This means the system may move you automatically depending on
the values you key and the underlying logic. You may continue to key data and move forward until the end of the case, or
you may use other keys to move around a case before you finish it.

As you move from field to field, the status bar at the bottom of the screen shows you the name and occurrence number of
the current field.

Add a Note

Field Notes

It sometimes is necessary to attach text to a data field in addition to the data value. For example, the enumerator may have
made a notation on the questionnaire which you want to preserve or the field may have an other specify response category
and you want to save the specified response. You can save such text by entering a note for the field.

To enter notes for data field, press Ctrl+N or from the Edit menu select Edit Field Note.

Case Notes

You can also add a case note, which is a single note associated with the entire case. This note is use for more general
information, such as information about a household or notes for a supervisor regarding specifics about the interview.

To add a case note, from the Edit menu select Edit Case Note.

See also: Notes File (.csnot)

Move Around a Case in Add Mode

CSEntry provides special keys to move among fields and forms within a case. You can work only on one case at a time.
Previous Field (Up arrow, Shift+Tab)

These keys move to the previous field in the current case. If your application has been designed as system-controlled type,
and you arrived at the current field by way of a programmed skip, the system will move you to the field from which you
skipped. Otherwise, the system will move you to the previous field on the form.

Next Field (Down arrow, Enter)
These keys move to the next field in the current case. The system obeys any skips programmed in the logic.
Previous Screen (PgUp)

For operator-controlled applications this key moves to the previous screen in the current case. If the current group is
multiple, but not rostered, this key moves to the beginning of the previous group occurrence. If the current group is single,
this key moves to the beginning of the previous group.

Next Screen (PgDn)

For operator-controlled applications, if you have backup up to a previous screen, this key moves forward to the next screen
in the current case (but not beyond the furthest point reached in the case). If the current group is multiple, but not rostered,
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this key moves to the beginning of the next group occurrence. If the current group is single, this key moves to the beginning
of the next group.

End Group Occurrence (/ on numeric keypad)

For operator-controlled applications, if the current group is multiple, this key moves to the beginning of the next group
occurrence. If the current group is single, this key moves to the beginning of the next group.

For example, if the operator has finished entering data for a person (a multiple group), he can use this key to start entering
data for the next person.

End Group (Ctrl+/)

For operator-controlled applications this key always moves to the beginning of the next group. This key is particularly
useful in multiple groups.

For example, if the operator has finished entering data for all persons, he can use this key to move to the next group, even if
there is room for more persons. This is an easy way get out of a roster.

End Level Occurrence (F12)

In operator-controlled applications: If the application has only one level, this key ends the case. If the application has more
than one level, use this key to end the current level occurrence, and begin a new level occurrence. For example, if the first
level is a mother questionnaire and the second level is a child questionnaire, pressing this key during a child questionnaire
means you have finished this child and wish to start the next child

In system-controlled applications: If you have moved backward, this key will advance you to the end of the current level
occurrence, or to the "furthest point" forward you have reached, if this is in the current level occurrence. This key is very
similar to the F10 key in this circumstance.

End Level (Ctrl+F12)

For operator-controlled applications, if the application has only one level, this key has no effect. If the application has more
than one level, this key is used at lower levels to signal that the keyer has finished all level occurrences at this level.

For example, if the first level is a mother questionnaire and the second level is a child questionnaire, pressing this key during
a child questionnaire means you have finished all children and wish to start a new mother.

Go To (F6)

This key allows you may to move to any field (either forward or backward). It is useful if you want to a field that is "far away"
or not on the current form. You must know the name of the field to which you want to move. If the field is multiply occurring
(on a roster, for example), you may also specify a specific occurrence number. If you leave the occurrence number blank the
system assumes the current occurrence number. You can see the field names and occurrence numbers on the status bar at
the bottom of the screen as you key data.

Previous Persistent (F7)

This key only has meaning if the application includes persistent fields. When you press this key the system will move to the
first persistent field it finds, previous to the current field, and place the cursor there. If there is more than one persistent
field, you may press F7 again to move again to the previous persistent field.

Advance to End (F10)

For system-controlled applications, if you have moved backward, this key will advance you to the "furthest point" forward
you have reached in the case.

Page 13 of 34 Add Cases



Skip to (+ on numeric keypad)

For operator-controlled applications, this key skips to the next field defined by the application. It is used to skip groups of
fields that may all be blank because they are not required to be answered by certain respondents.

See also: Move Around a Case in Modify Mode

Finish a Case

Normally you finish a case when you have completed entering all the forms in the case. CSEntry asks you whether you want
to accept the case or not. If you accept the case, CSEntry immediately writes the case to the data file.

In system-controlled applications the operator must enter data field-by-field until reaching the end of the case. Exactly
when the end of the case is reached is determined by logic. There are no special keys to finish a case prematurely. In
applications with more than one level, the application developer must write logic to tell CSEntry when to finish entering level
occurrences.

In operator-controlled applications, the operator may press F12 or Ctrl-F12 to end a case at any time.

View or Hide Response Box

In a CAPI data entry application, you can show or hide responses for the current field or all fields.
To show or hide responses for this field, press Ctrl+C or from the Options menu, select Show Responses (This Field).
To show of hide responses for all fields, press Ctrl+K or from the Options menu, select Show Responses (All Fields).

You can also move the response box around on the screen using the mouse.

Change CAPI Language

In a CAPI data entry application, you can change the question language at any time.

Press Ctrl+L or from the Options menu, select Change CAPI Language. A dlialog box will come up to allow you to select
question and help text from among the available languages.
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Modify Cases

Select a Case

Use any of the following methods to select a case to view and/or modify.
e From the File Tree move the highlight bar to or click on the case ID. Then press Ctrl+M or from the File menu, select
Modify Case.
e From the File Tree, double click on the case ID.

e Press Ctrl+F or from the Edit menu, select Find Case. Then enter the case ID. The case ID must be entered exactly as
it appears in the file.

Begin Modifying Cases

When you have selected where you want to start modifying cases, press Ctrl+M; from the Mode menu, select Modify; or
clickzﬁzI on the toolbar to begin modifying. This will begin a new Modify mode session, or pick up where you last left off, if
this was a partially modified case. You may move through cases viewing as many as you like, but once you begin modifying a
case, you must finish the modify session before you can begin viewing another case.

The session will end when you stop modifying the current case. You can stop modifying a case by finishing it, or partially
saving the modifications.

Partially modified cases are marked with & in the file tree. You can modify these cases as well as any other completed
cases. You cannot modify partially added or verified cases.

Save Partially Modified Case

In order to save a partially modified case, two conditions must be met.

The most important condition is that during development of the data entry application, the partial feature must have been
selected. During modification if you attempt to exit the case by pressing Esc or Ctrl+S, the Partial Save button will appear on
the Stop Modifying dialog box.

The second condition is that you must have changed one of the field values in the case. If you have, the Partial Save button

will be enabled on the Stop Modifying dialog box. Choosing it will save the case, remembering the field your cursor was last
on, returning you to this field when modification is resumed.

Move Between Cases

Once you have finished modifying (or simply viewing) a case, you may move to a different case in one of the following ways:

e From the File Tree move the highlight bar to or click on a different case ID.
e Use the toolbar to select first, previous, next or last case in the data file.
e From the Navigation menu select First Case, Previous Case, Next Case, or Last Case.

e Use the special keys to select first, previous, next or last case in the data file.
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Insert a Case

1. Make sure you are not in Add, Modify, or Verify mode. You may need to stop (Ctrl+S) data entry first.
2. From the File Tree move the highlight bar to or click on the case ID where you want to insert the case.

3. Press Ctrl+Ins or from the Edit menu, select Insert Case.

Delete a Case

1. Make sure you are not in Add, Modify, or Verify mode. You may need to stop (Ctrl+S) data entry first.
2. From the File Tree move the highlight bar to or click on the case ID you want to delete.

3. Press Ctrl+Del or from the Edit menu, select Delete Case.

Change Case IDs

1. Select the case whose IDs you wish to change.
2. Switch to Modify mode.
3. Keyinthe new IDs.

4. Save the case.

CSEntry will ensure that no two cases in the same data file have the same IDs.

Move Around a Case in Modify Mode

Moving around a case in Modify mode is very similar to moving around in Add mode. However there are some differences:

Next Screen (PgDn)

For operator-controlled applications this key always moves to the next screen in the current case. In Add mode, this key is
only in effect if you have backed up to a previous screen.

End Level Occurrence (F12)

Operator-controlled applications: If the application has only one level, this key saves the case, including any changes you
have made. If the application has more than one level, this key has no effect. (Use Ctrl+F12 to save the case in this situation.)

System-controlled applications: This key advances to the beginning of the next level occurrence.

End Level (Ctrl+F12)

For operator-controlled applications this key saves the case, including any changes you have made.

Advance to End (F10)

For system-controlled applications this key will attempt to save the case. It will execute all the procedures from the
current field through the end of the case. The application may contain underlying logic which stops you at a certain point
and displays a message. The system will only save the case if there are no such messages.

See also: Move Around a Case in Add Mode
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Go to a Field

1. Enter the field name as defined in the data entry application.

2. Enter the field occurrence number, if the field has multiple occurrences.

A field can have multiple occurrences because it appears in a roster or because it appears on repeating forms. If the filed
does not have multiple occurrences or you want to go to the first occurrence, leave the field occurrence number blank.

Insert a Group Occurrence

You can insert an occurrence to any multiple group whether the group is represented by a roster or a form that repeats.

1. In Add or Modify mode, position the cursor to the group occurrence before or after which you want to insert, for
example a particular line on a roster.

2. Toinsert before the current position, press F3, or from the Edit menu, select Insert Group Occ.

3. Toinsert after the current position, press Ctrl+F3, or or from the Edit menu, select Insert Group Occ After.

See also: Repeating Groups of Fields, Delete a Group Occurrence, Sort a Group Occurrence

Delete a Group Occurrence

You can delete an occurrence to any multiple group whether the group is represented by a roster or a form that repeats.

1. In Add or Modify mode, position the cursor to the group occurrence you want to delete, for example a particular line
on a roster.

2. PressF4, or from the Edit menu, select Delete Group Occ.

See also: Repeating Groups of Fields, Sort a Group Occurrence, Insert a Group Occurrence

Sort a Group Occurrence

CSEntry allows the operator to sort group occurrences while in Add or Modify mode from any of the fields that belong to the
group. For example, if you have a roster or repeating form, and you are currently on one of the fields located within that
roster or repeating form, you may sort the data by pressing F5.

The group data will be always be sorted in ascending order. It will sort the data based on the current field selected; that is,
based on the location of the cursor. Therefore, if you are in the AGE field of the population group and press F5, the
population records will be sorted by age, showing youngest person first.

See also: Repeating Groups of Fields, Insert a Group Occurrence, Delete a Group Occurrence

Select a Level Occurrence

This applies only to complex applications that have more than one level.

1. Make sure you are not in Add, Modify, or Verify mode. You may need to stop (Ctrl+S) data entry first.
2. Expand the File Tree for the case which contains the level occurrence of interest.

3. Move the highlight bar or click on level occurrence of interest.
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Add a Level Occurrence

This applies only to complex applications that have more than one level.

1. Make sure you are not in Add, Modify, or Verify mode. You may need to stop (Ctrl+S) data entry first.
2. Select the case ID on the File Tree for the case into which you want to add level occurrence.

3. Press Alt+A; from the Edit menu, select Add Level Occ; or right click and select Add Level Occ.

Insert a Level Occurrence

This applies only to complex applications that have more than one level.

1. Make sure you are not in Add, Modify, or Verify mode. You may need to stop (Ctrl+S) data entry first.
2. Expand the File Tree for the case into which you want to insert a level occurrence.
3. Select the level occurrence before which you want to insert.

4. Press Alt+Ins; from the Edit menu, select Insert Level Occ; or right click and select Insert Level Occ.

Delete a Level Occurrence

This applies only to complex applications that have more than one level.

1. Make sure you are not in Add, Modify, or Verify mode. You may need to stop (Ctrl+S) data entry first.
2. Expand the File Tree for the case in which you want to delete a level occurrence.
3. Select the level occurrence you want to delete.

4. Press Alt+Del; from the Edit menu, select Delete Level Occ; or right click and select Delete Level Occ.

Save a Case

Saving a case will write the contents of the current case to the data file, including any changes you have made. This includes
all records, of all types, into which data have been entered. If a record type has been declared Required (in the data
dictionary), and no data was entered for this record type, a blank record of the required type will be written as part of the
questionnaire, and a message informing you of this action will be issued. There is no way to suppress this message. Records
are written to the output file in the order in which the record types were defined in the data dictionary.

If the application is defined as operator-controlled, you may use the F12 or Ctrl+F12 keys to save a case. If the application is
one level (most common), use either key. If the application is more than one level, use the Ctrl+F12 key.

If the application is defined as system-controlled type, you may use the F10 key (Advance to End) to save a case. This key
will execute all the procedures from the current field through the end of the case. The application may contain underlying
logic which stops you at a certain point and displays a message. The system will only save the case if there are no such
messages.

The following is true for both operator and system-controlled mode:

e [fyouare inadd mode, saving the case will keep you in add mode, allowing the operator to continue adding cases.

e If you are in modify mode, saving the case will terminate modify mode. The operator has to select a new case and to
get back into modify mode.
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Edit Interactively

You can search through the data file using your data entry logic to find errors or unexpected conditions and display the data
entry form containing each error ready for modification. This is a very convenient way to make corrections to survey data,
provided the data volume is not too large, and the operator is knowledgeable enough to make the necessary corrections.

Interactive editing is performed after the data have already been entered. You can use the same programmed logic that
was in effect during data entry to find problems that were left unresolved by the original keyer, or you can use different logic
to check for other conditions.

To perform interactive editing:

1. Open the data file, using the data entry application that contains the logic you want to check.
2. Go to Modify mode, starting on the first case you wish to check (usually the first case in the data file).
3. From the Edit menu, select Interactive Edit; or press F11.

4. Select whether to stop on messages, out of range conditions, or both.

CSEntry will advance from wherever the cursor is currently positioned, field by field, from the current case through the end
of the data file, executing whatever procedures are included in the application’s logic. If you have chosen to stop on
messages, CSEntry will stop whenever the application logic hits an "errmsg" command. If you have chosen to stop on out of
range, CSEntry will stop whenever a field value is other than what is defined in its first value set in the dictionary. (If there
are no value sets for a given field, it will never be considered out of range.) When CSEntry stops, it shows the programmed or
out or range message, then places you on the appropriate form. You can make changes to the data if you like, and press F11
to continue through the data file.
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Verify Cases

Begin Verifying Cases

Press Ctrl+V; or from the Mode menu, select Verify; or click B on the toolbar to begin verifying cases from the beginning of
the data file or where you left off verifying. This will begin a new Verify mode session. CSEntry keeps track of the last case
that was verified, and positions you automatically to the next case to verify.

If you did not complete verifying the last case, there will be a partially verified case in the data file marked with i the file
tree. When you begin verification, you will be asked whether you want to begin verification where you left off within the
case.

You cannot verify cases if there are partially added or partially modified cases in the file. You must finish these cases before
you can resume verification.

You may verify as many cases as you like until you reach the end of the data file.

Save Partially Verified Case

In order to save a partially verified case, two conditions must be met.

The most important condition is that during development of the data entry application, the partial feature must have been
selected. During verification if you attempt to exit the case by pressing Esc or Ctrl+S, the Partial Save button will appear on

the Stop Verifying dialog box.

The second condition is that you must have verified all ID fields in the case. If you have, the Partial Save button will be
enabled on the Stop Verifying dialog box. Choosing it will save the case, remembering the field your cursor was last on, and
returning you to this field when verification is resumed.

Verify Data

When you verify a case, you key the case a second time as if you were in Add mode. Even though there is already data in the
data file, CSEntry does not show this to you. All fields on the current form start out blank. Each time you key a field, the
system compares the value you keyed with the value in the data file. If these two values match, you move to the next field. If
the values do not match, you get a message telling you so. When this happens, simply rekey the field. One of the following
situations will occur:

e The second value you key matches the value in the data file. The system assumes your first value is in error and moves
to the next field. There will be no change to the data file for this field.

¢ The second value you key matches the first value you keyed. The system assumes the value in the data file isin error
and moves to the next field. The new value, which you keyed twice, will replace the original value in the data file.

e The second value you key matches neither the value in the data file nor the first value you keyed. The system will
throw away the first value you keyed, show you the mismatch message and wait for you to rekey the field again.

Show Fields

Sometimes you need to see the values in the data file on the screen. This is particularly useful if you are unsure which case
you are verifying or exactly where in the case you are. You can use the Ctrl+F2 key to do this. When you press the Ctrl+F2 key
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you will see the values for all the fields on the current form. You must press Ctrl+F2 again to resume verifying.

Active Keys in Verify Mode

Moving around a case in Verify mode is much more restricted than in Add or Modify mode. However, you can use the
following keys:

e Previous Field (Up arrow, Shift+Tab)

e Next Field (Down arrow, Enter)

e End Group Occurrence (/ on numeric keypad) (operator-controlled applications only)

e End Group (Ctrl + /) (operator-controlled applications only)

e End Level Occurrence (F12)

e End Level (Ctrl + F12) (operator-controlled applications only)

e Previous Persistent (F7)

e Advance to End (F10) (system-controlled applications only)
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Stop Work

Stop Data Entry

To stop data entry press Esc or Ctrl+S; click Stop Button on the toolbar; or from the Mode menu select Stop. This function
has no effect if you are already stopped. Stopping add, modify, or verify will make an entry into the operator statistics file.

If you are at the beginning of a case or have not made any changes, the session will end immediately.

If you have started, but not completed entry/modification/verification of a case, two or more of the following choices will
appear depending on the mode of data entry and whether partial save is allowed:

Option Description

Partial Save Partially save the changes you have made so far and remember the field you are on, so you can
complete the work later. Available only if partial save is possible. In add and verify mode, all ID fields
must have been entered.

Finish Finish the case and save the modifications you have made. Available only in modify mode.
Discard Discard all the changes you have made since you opened this case. Always available.
Cancel Cancel this operation and return to entering the case. Always available.

Save Partial Case

If the application allows saving partial cases, then if you press Esc or Ctrl+S before completing the questionnaire, you will be
asked whether you want to save the case partially or discard the changes.

If you want to save what you’ve done so far but continue, press Ctrl+R or from the File menu, select Save Partial Case.

Pause Data Entry

To pause data entry press Ctrl+P; click I on the toolbar; or from the Mode menu select Pause.

Whenever you are in Add, Modify, or Verify mode, a timer is running. This timer is used to generate the operator statistics
for the data entry session. Pause (Ctrl+P) stops the timer until you either resume typing or press Ctrl+P again.

The timer affects the calculation of keystrokes/hour. If you need to leave the computer for a few minutes, but are in the
middle of a session, you should pause data entry so that time will not be counted against you.
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Assess Performance

View Operator Statistics

To view operator statistics press Ctrl+W or from the View menu, select Operator Statistics. You can view statistics only
when you are in stop mode; that is, when you have stopped adding, modifying, or verifying cases.

CSEntry shows the number of cases in the data file and the number of cases which have been verified. CSEntry also provides
information about each operator who has worked on the current data file. This information is stored in the log file.

Each line represents one data entry session.

Clicking in the gray heading area for any column will sort the information in that column. Successive clicking of the column
heading toggles that column's data between an ascending or descending sort.

Understand Operator Statistics

Mode

Indicates the mode (Add, Modify, or Verify) in which the operator was working during the session. Every time an operator
works on the current file, in any mode, an entry is created for that session.

Operator ID

Displays the personal ID assigned to the operator of the relevant session. To ensure reliable statistics, this ID must be unique
for each data entry operator.

Start Date

Indicates the date on which the session began. The date format is DD/MM/YYYY (i.e., Day/Month/Year).

Start Time

Indicates the time at which the session began. The system uses a 24-hr clock, so 2:30 pm will appear as 14:30.
Total Elapsed Time

Indicates the total time elapsed during the session in question. The format shown is HH:MM (i.e., hours:minutes).
Pause Time

Indicates the total amount of time during the session in which the clock was suspended. The format shown is HH:MM (i.e.,
hours:minutes).

Total Cases

Indicates the total number of cases that the operator added (if in Add mode), modified (if in Modify mode), or verified (if in
Verify mode) during the session.
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Total Records

Indicates the total number of records, of all types, that the operator added (if in Add Mode), modified (if in Modify mode), or
verified (if in Verify mode) during the session.

Total Keystrokes/Hr

Indicates the operator's keying rate during the relevant session. The total number of keystrokes is divided by the duration of
the session, excluding the pause time, and displayed as an integer value.

Errors/1000 Keystrokes

Is the result of a two-step calculation: the total number of keying errors (an internal counter maintained by the system but
not displayed) is multiplied by 1000; the result of this operation is divided by the total number of keystrokes for the session;
the result of the division operation is rounded, if necessary, and displayed as an integer value.

Percentage of Fields With Verify Errors Attributed to Keyer

Verify errors are attributed to the keyer if the final value of a field, after verification, is different from the value entered by
the keyer. The number of verify errors attributed to the keyer is divided by the total number of fields verified and displayed
as a percentage with one decimal place.

Percentage of Fields With Verify Errors Attributed to Verifier

Verify errors are attributed to the verifier if the final value in the field, after verification, is the same as that entered by the
keyer, but was changed by the verifier before returning to the originally-keyed value. The number of verify errors attributed
to the verifier is divided by the total number of fields verified and displayed as a percentage with one decimal place.

Percentage of Fields With Any Verify Errors

The number of verify errors attributed to the keyer and the number attributed to the verifier are added together and
divided by the total number of fields verified and displayed as a percentage with one decimal place.
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Synchronize

Synchronize Data

A data entry application may be able to synchronize data with a remote server. If so, the Synchronize menu option (off the
File menu) will be enabled when you are not currently working in any case. When you select this option, CSEntry will attempt
to connect to the remote server and then synchronize data, as well as possibly the data entry application itself, using
parameters specified by the application programmer.

You may have to enter a username and/or password before the synchronization process begins.
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Change Views and Get Help

Change View

Full Screen

To toggle between trees on left and full screen press Ctrl+J, or from the View menu, select Full Screen. A check mark
appears next to the Full Screen menu item when the display is in full screen mode. The setting of Full Screen remains in effect
until changed.

Show Case Labels

To toggle between showing the case case labels (if they exist) rather than case IDs in the file tree, from the View menu,
select Show Case Labels. A check mark appears next to the Show Case Labels menu item when CSEntry is showing case
labels. If there is no check mark, the case IDs will be displayed. By default case labels are shown.

Cases in Sort Order

To toggle between cases in physical or sort order press Ctrl+Q, or from the View menu, select Cases in Sort Order. A check
mark appears next to the Cases in Sort Order menu item when cases are sorted by identification items. If there is no check
mark, the cases appear in the physical order they occur in the data file.

View Partials Only

To toggle File Tree between all cases and partial cases only press Ctrl+B, or from the View menu, select View Partials Only.
A check mark appears next to the View Partials Only menu item when only partial cases appear in the File Tree. If there is no
check mark, the all cases appear in File Tree.

Case Tree

To toggle the Case Tree on or off press Ctrl+Z, or from the View menu, select Case Tree. A check mark appears next to the
Case Tree menu item when the Case Tree is displayed. If there is no check mark, the File Tree is displayed.

Names in Case Tree

To toggle between labels and names in trees press Ctri+T, or from the View menu, select Names in Trees. A check mark
appears next to the Names in Trees menu item when names are displayed instead of labels. The setting of Names in Trees
affects the Case Tree.

Show Values

To show all data values in verify mode press Ctrl+F2, or from the View menu, select Show Values (verify). Pressing Ctrl+Z or
keying values will return data entry to verify mode.

Operator Statistics

To show operator statistics press Ctrl+W, or from the View menu, select Operator Statistics. A dialog box containing all the
operator statistics for this data file will be displayed.

Get Help
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To contact the CSPro development team with comments, questions, or to report problems, please contact:

International Programs
Population Division
U.S. Census Bureau

4600 Silver Hill Road
Washington, DC 20233

Phone: +1 301-763-1451

Support email: cspro@ lists.census.gov

Official website: www.census.gov/data/software/cspro.html

CSPro Users forum: www.csprousers.org/forum

When you contact us, please mention that you are using CSPro 7.3.0.
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Files

Types of Files

CSEntry manipulates one primary data file. This is the file where the cases you add, modify or verify are stored. There may be
other external data files associated with an application, such as lookup files.

There are often other files associated with the primary data file. They have the same name as the primary data file with the
following extensions added:

Extension File

.csidx Index
st Listing
.csnot Notes
.log Operator statistics

.Sts Status

If using the CSPro DB file format, the data contained in the index, notes, and status files is embedded within the CSPro DB
file.

Index File (.csidx)

The index file stores the case IDs and their physical location in the data file. This helps CSPro applications manipulate the
data file more quickly. The file is a binary file and should not be modified file outside of CSPro.

CSPro automatically generates an index file when creating a new data file. CSPro then coordinates between both files as
cases are added, modified, or deleted.

When CSPro opens a data file, it looks for the corresponding index file. If it does not find one, CSPro automatically generates
a new one. If you suspect, for any reason, that the index file has been corrupted, or does not match the data file, simply
delete the index file and let CSPro generate a new one.

An index is only created for text files. Prior to CSPro 7.0, the data file index had the extension .idx.

Operator Statistics File (.log)

The log file stores operator statistics generated by CSEntry for a corresponding data file. CSEntry creates a log file when it
creates a new data file. The log file is a comma-delimited text file with a fixed format. It is designed to be easily imported
into other software packages for custom processing. The log file can also be processed by CSPro application with the
appropriate data dictionary.

Each record in the log file represents one data entry session. The record layout is as follows:

Position Contents

1-3 Mode (ADD, MOD, or VER)
4 comma

5-36 Operator ID (as entered)
37 comma
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38-47 Start date (mm/dd/yyyy)

48 comma

49 - 56 Start time (hh:mm:ss)

57 comma

58 -65 End time (hh:mm:ss)

66 comma

67-74 Total time (End time - Start time) (seconds)
75 comma

76-83 Pause time (seconds)

84 comma

85-92 Number of cases written

93 comma

94 -101 Number of records written

102 comma

103-110 Number of keystrokes

111 comma

112-119 Number of bad keystrokes

120 comma

121-128 Number of fields with errors attributed to keyer
129 comma

130-137 Number of fields with errors attributed to verifyer
138 comma

139 - 146 Total number of fields verified

Listing File (.Ist)

The listing file stores information about each time an application was run using the associated data file. It gives the following
information:

e The names of the files used.

e The start and end time of the run.

e Any error messages, both user and system messages, which occurred during the run.
The listing file associated with a batch edit application is often the primary output of the application. For most other

applications and tools the listing file is a secondary output. For data entry applications, this file can be useful for monitoring
the work of keyers in training and identifying problem keyers.

Notes File (.csnot)

The notes file is a text file that contains all notes processed by a data entry application. The file contains the case IDs, the
name of the data item to which each note belongs, the name of the operator, the time the note was left, and the note text.
There may be multiple note records for a particular field.

The format of each note record is as follows:

e The first N characters are the case IDs.

e The next 32 characters are the field name as given in the dictionary (left justified). If you use field names longer than
32 characters, the field name will be encoded in a way so that it fits in 32 characters. You can use the
NOTES_FIELD_VS value set of the notes dictionary to figure out which note is which.

e The next 32 characters are the name of the operator ID (left justified).
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e The next 8 characters are the date the note was last modified (YYYYMMDD).

e The next 6 characters are the time the note was last modified (HHMMSS).

e The next 5 characters are the record occurrence number if applicable (right justified).
e The next 5 characters are the item occurrence number if applicable (right justified).

e The next 5 characters are the subitem occurrence number if applicable (right justified).

e The remaining characters are the note text.

Note text can contain "\n" characters, which indicate a newline (Enter key) character. If the note text is automatically
wrapped in the note text box, there will be no newline characters.

The .csnot file can be processed by another CSPro application by creating a data dictionary for it. You can use the Dictionary
Macros function to automatically create this dictionary.

Notes can be created, edited, and deleted using the getnote, putnote, and editnote functions.

Notes for CSPro DB files are stored within the file itself and not in a .csnot file. Prior to CSPro 7.0, the notes file had the
extension .not.

Status File (.sts)

The status file stores information about which cases are partially entered and the last field entered. It also keeps track of the
cases that have been verified. CSEntry uses this information to:

e Show which cases in the data file are partially entered.
e Restart partially entered cases at the last field location entered.

e Show the number and percent of verified cases in the operator statistics.
The .sts file is a text file and you can view this file in Text Viewer.

If necessary, you can modify this file in a text editor. However, you should manipulate this file with extreme caution. If you
modify it incorrectly, you can lose information about partially entered cases or which cases have been verified.

Status information for CSPro DB files is stored within the file itself and not in a .sts file.
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summaries

Menu Summary

The following is a summary of the Text Viewer menus:

File
Open Application

Open Data File
Save Partial Case

Synchronize

Mode

Add Case
Modify Case
Verify Case
Pause

Stop

Edit

Insert Case
Delete Case

Find Case

Insert Level Occ
Add Level Occ
Delete Level Occ

Insert Group Occ

Insert Group Occ After

Delete Group Occ
Sort Group Occ
Edit Field Note
Edit Case Note

Interactive Edit

Navigation
Previous Screen
Next Screen
First Case
Previous Case
Next Case

Last Case

End Group Occurrence

End Group
End Level Occurrence

End Level
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Open a new data entry application.

Open a new file for data entry in the current application.

Partially save the current case and continue entry.

Synchronize the data with a remote server.

Switch to add mode.

Switch to modify mode.

Switch to verify mode.

Pause data entry (stops statistics clock).

Stop data entry in current mode.

Insert new case.

Delete selected case.

Find case with particular identifier.

Insert a new level before the current level.
Add a new level at the end of this level.

Delete the selected level within a case.

Insert a new occurrence before this occurrence.
Insert a new occurrence after this occurrence.
Delete this occurrence.

Sort occurrences based on values of this field.
Add, modify, or delete field note.

Add, modify, or delete a case note.

Search cases for range and/or edit errors (in modify mode).

Skip to previous screen.

Advance to next screen.

Go to first case in tree order.

Go to previous case in tree order.

Go to next case in tree order

Goto last case in tree order.

Skip to next occurrence of this group of fields.
Skip to next field after this group of fields.
Skip to next occurrence of this level.

Skip to next level after this level.
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Advance to End
GoTo
Previous Persistent

View
Full Screen

Show Case Labels

Cases in Sort Order

View Partial Cases Only

Case Tree

Names in Case Tree

Show Values (verify)

Operator Statistics

Options

Interactive Edit Options

Change Language

Show Responses (This Field)

Show Responses (All Fields)

Help

Help Topics
About Data Entry

Advance to the furthest point reached.
Go to a particular field in the current case.

Go to previous persistent field.

Hide the trees and show full screen view.

Show case labels (if they exist) rather than case IDs in the file tree.
Show cases in file tree in sort order rather than physical order.
Show only partial cases in file tree.

Toggles the case tree on and off.

Show names in case tree.

Show all data values (in verify mode).

Show operator statistics data file.

Change search options for interactive edit.
Change current language of the CAPI question text.
Show or hide response box for this field.

Show or hide response box for this and all other fields.

Get help on current application.

Get information about the software.

Toolbar Summary

The CSEntry toolbar is displayed across the top of the window, below the menu bar. It provides quick mouse access to many
features used in Sort Data. Click to:

Open a data file.
Add case.

Modify case.

Verify case.
Pause the timer.
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Get help.

Stop adding or modifying.

Goto first case in tree order.

Go to previous case in tree order.
Go to next case in tree order.

Go to last case in tree order.

Keys Summary

Shortcuts specific to CSEntry

Shortcut Key

Description

Ctrl+ A
Ctrl+B
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Add cases to the data file.

View partial cases only.
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Ctrl+C Show responses for this field only.

Ctrl+D Open another data file.

Ctrl+F Find a case.

Ctrl+ G Toggle between tree and form.

Ctrl +) Toggle full screen on and off.

Ctrl + K Show responses for all fields.

Ctrl+ M Modify cases in the data file.

Ctrl+ N Edit field notes.

Ctrl+ 0O Open an existing application.

Ctrl+ P Pause entry operations to take a break.
Ctrl+Q Show case list in sort or physical order.
Ctrl+S Stop data entry operations.

Ctrl+T Show names in tree instead of labels.
Ctrl+V Verify cases in the data file.

Ctrl+ W Show operator statistics data file.
Ctrl+ 2 Toggle the Case Tree on and off.
Alt+A Add level occurrence to this case.

Alt +Ins Insert level occurrence at this location.
Alt + Del Delete this level occurrence.

Ins Insert case at this location.

Del Delete this case.

Enter Move forward to the next field.

Tab Move forward to the next field.

Dn arrow Move forward to the next field.

Up arrow Move backward to the previous field.
Shift + Tab Move backward to the previous field.
PgDn Next screen (in operator-controlled mode).
PgUp Previous screen (in operator-controlled mode).

/ (num keypad) End group occurrence (in operator-controlled mode).
Ctrl+/ End group (in operator-controlled mode).

+ (num keypad)  Skip to (in operator-controlled mode).

Ctrl+Home Move to the first case in the file (in modify mode).
Ctrl+PgUp Move to the previous case in the file (in modify mode).
Ctrl+PgDn Move to the next case in the file (in modify mode).
Ctrl+End Move to the last case in the file (in modify mode).

F1 Show help contents and index.

F2 Show help for a field (in CAPI mode).

Ctrl + F2 Show data values (in verify mode).

F3 Insert another occurrence of these fields here.

Ctrl + F3 Insert another occurrence of these fields after this one.
F4 Delete this occurrence of these fields.

Alt + F4 Quit the application.

F5 Sort occurrences of these fields on this field.

F6 Go to a particular field.
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F7

F10

F11

F12

Ctrl + F12
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Go to previous persistent field.

Advance to end of the case (in system-controlled mode).

Start or continue interactive edit (in modify mode).
Go to the next level occurrence at this level.

Go to the next level occurrence at the level above this.
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