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CSPro Getting Started Guide

Introduction
What is CSPro?
The Census and Survey Processing System (CSPro) is a software package for entry, editing, tabulation, and dissemination of
census and survey data. CSPro combines the features of the Integrated Microcomputer Processing System (IMPS) and the
Integrated System for Survey Analysis (ISSA).

CSPro lets you create, modify, and run data entry, batch editing, and tabulation applications in a single, integrated
development environment. It processes data on a case basis (one or more questionnaires), where a case can consist of one
or many data records. The data are stored in files described by data dictionaries. CSPro contains a powerful common
procedure language to implement data entry control and edit rules.

CSPro also provides tools to view data and other text files, to view tables and thematic maps created by CSPro, to convert
IMPS and ISSA data dictionaries to and from CSPro, and to convert ERSI shape files (maps) to CSPro map files.

CSPro was developed jointly by the U.S. Census Bureau, ICF International, and Serpro, S.A., with major funding from the U.S.
Agency for International Development.

CSPro is in the public domain. It is available at no cost and may be freely distributed. It is available for download at
www.census.gov/data/software/cspro.html.

This guide contains information about installing and uninstalling CSPro, followed by a tutorial that will guide you through a
series of exercises to help you get started using CSPro.

CSPro Features
This is an overview of some of CSPro's main capabilities. You can also view information about CSPro's tools.

Data Entry

Add, modify, verify and view cases (questionnaires). Create an unlimited number of forms (screens). Create forms bigger
than the computer screen that scroll as necessary. Create forms with fields from different physical records. Enter data from
rosters. Create consistency checks and skip patterns of unlimited complexity. Execute procedures before and/or after field is
entered. Display user-defined messages. Access multiple lookup files. Read from and write to secondary files. Index cases to
avoid duplication. Produce operator statistics. Create a stand-alone data entry environment.

Batch Editing

Identify and report structure, value, and consistency errors in questionnaire data. Change (impute) data values based on
simple or complex methods. Produce summary or detailed reports of errors and corrections. Access multiple lookup files.
Read from and write to secondary files.

Tabulation
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Define and select variables to tabulate. Select the universe of tabulation. Tabulate values and weights. Format tabulations
for viewing or printing. Save tabulations in several formats. Copy tables to spreadsheets or word-processing documents.
Produce tables by geographic area. Map results by geographic area.

Data Dictionary

Define simple or complex hierarchical file organization. Define hierarchical levels, identification items, records, items (fields
or variables), value sets (categories of values), and values. Create descriptive notes for documentation. Define multiply
occurring items and define relationships between multiply occurring records and items. Produce reports of file organization.
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Installation
Hardware and Software Requirements
The minimal configuration for CSPro is:

Pentium processor

512MB of RAM

SVGA monitor

Mouse

100MB of free hard drive space

Microsoft Windows Vista, 7, 8, or 10

Installing CSPro
The CSPro installer has the file name cspro72.exe. To install CSPro:

1. Double-click on the file.

2. Read and accept the U.S. Census Bureau's license agreement

3. Select the components that you want to install. You will generally want to install all of the components.

4. Select the folder where you want to install CSPro. You will generally want to install CSPro in the suggested directory.

After CSPro has been installed on your computer, you will have the option to run the program and/or view the release notes.

You will find a CSPro 7.2 icon on your desktop that you can double-click on when you want to run CSPro in the future.

Installing a Newer Version
Upgrading to CSPro 7.2 From CSPro 7.1 or Earlier

If you have an old version of CSPro installed on your computer, you can install CSPro 7.2 without affecting the previous
version. When you have finished your conversion of applications to CSPro 7.0, you can then uninstall the previous version.

Due to internal changes within CSPro 7.2, once files have been loaded in CSPro 7.2, you may no longer be able to load them
in previous versions of CSPro.

Updating a Previous Version of CSPro 7.2

If you are updating a previous version of CSPro 7.2, the installer will remove the previous version and replace it with the new
version. It will not change any applications or other files that you have created.

Uninstalling CSPro
There are two ways to uninstall CSPro. The uninstaller will remove all registry entries and CSPro system files. It will not
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remove any applications or other files that you have created.

You can uninstall the program using the Windows Control Panel:

1. Using the Windows search functionality (Windows Key+S), type Add or remove programs.

2. Select CSPro from the list of programs.

3. Follow the prompts to uninstall the program.

Alternatively, you can:

1. Use Windows Explorer to browse to the CSPro application folder, which will likely be: C:\Program Files (x86)\CSPro
7.2.

2. Run the program uninstall.exe.

3. Follow the prompts to uninstall the program.
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CSPro Tutorial
About the Tutorial
The tutorial will guide you through a series of exercises to help you get started using CSPro.

The exercises in the tutorial require no special knowledge other than basic familiarity with Windows. The exercises are
divided into very short steps. Each step normally takes only a few minutes.

There are eight exercises. You will files in each exercise that are used in later exercises. Exercises 1 through 6 show you
simple data entry and cross tabulation. Exercises 7 and 8 show you the CSPro language for editing.

1. Create a Data Entry Application (3 steps)

2. Create the Data Dictionary (4 steps)

3. Create the Data Entry Forms (3 steps)

4. Enter Data (4 steps)

5. Tabulate Data (3 steps)

6. Modify the Table (3 steps)

7. Add Edits to the Data Entry Application (4 steps)

8. Run a Batch Application (4 steps)
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Exercise 1: Create a Data
Entry Application

Step 1: Examine the Tutorial Questionnaire
(Exercise 1, Create a Data Entry Application)

The tutorial exercises are based on a sample questionnaire. In Exercises 1 through 6 we will create a data entry application,
key some data, then tabulate the data. In Exercises 7 and 8 we go back and add a consistency check.

Note the following about the sample questionnaire:

Each questionnaire corresponds to a household.

Each questionnaire (household) has a unique four-digit number at the top.

We collect age, sex, and marital status for up to ten people in the household.

We collect type of housing and roof for the household.

Continue to the next step: Step 2: Start CSPro.
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Step 2: Start CSPro
(Exercise 1, Create a Data Entry Application)

First, create a new folder for all files you will use in this tutorial. Open Windows Explorer and create a folder named
C:\CSProTutorial.

Now you are ready to start CSPro, which you can by double-clicking on the CSPro 7.2 icon on your desktop, or by finding the
proper link off the Start menu.

The CSPro main screen will appear:

Continue to the next step: Step 3: Naming Application Files.

Step 3: Naming Application Files
(Exercise 1, Create a Data Entry Application)

We will create a data entry application. This contains:

Data dictionary: The data dictionary describes the organization of the data file. It holds information about all the
questions and responses on the questionnaire.

Forms: The forms will appear on the screen when you run the data entry application. They contain data entry fields,
text, and rosters.
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Logic (optional): You can use the CSPro language to control the flow of your program, to write logic to check for
errors during data entry, to access lookup files, and many other things. We will not use logic until Exercise 6.

We will use the Wizard to create the files that the data entry application requires. Click on the radio button that says Create
a new application. You should see the following dialog box:

1. Select Data Entry Application and press OK.

2. In the file open dialog box, enter MyEntry as the file name for the application.

3. Make sure you are located in the folder you created for these exercises (C:\CSProTutorial).

4. Press Save.

5. The next screen will ask you to select the Input Dictionary.

6. Change the name to C:\CSProTutorial\MyDict.dcf.

7. Press OK.

8. CSPro will ask if you want to create a new dictionary. Press Yes.

You have created a new data entry application

This completes this exercise. Continue to the next exercise: Step 1: The ID Item.
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Exercise 2: Create the Data
Dictionary

Step 1: The ID Item
(Exercise 2, Create the Data Dictionary)

We will make our dictionary first, then our forms. CSPro automatically generates a skeleton data dictionary. We will change
it and add our own information.

Every data dictionary requires at least one ID item, and you will often have more than one. An ID (identification) item is a
unique number (or series of numbers) that allows CSPro to distinguish between individual questionnaires. CSPro requires at
least one ID item.

1. Click on (Id Items), then on the '+' next to it to open the tree on the left side of the screen. You will see that CSPro has
created one ID item. On the right side of the screen you will see in the Len column that this item has the length of
one character. We will make this four characters.

2. Right-click on MyDict identification, below (Id Items) on the tree, and then select Modify Item.

3. Press the Enter key three times until the length is highlighted in blue.

4. Type 4 and then Enter, then click on the white space below this line to finish making this change.

When you have completed this step the screen should look something like:
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Continue to the next step: Step 2: The Records.

Step 2: The Records
(Exercise 2, Create the Data Dictionary)

A record usually corresponds to a section of a questionnaire and consists of a group of related questions.

By default, CSPro creates one record. Our tutorial application will have two records, a Person Record and a Housing
Record. We will change the one record that CSPro generated to Person Record, and then add the Housing Record.

First, we will change the one record that CSPro generated to Person Record:

1. Right-click on MyDict record on the tree on the left, then select Modify Record.

2. Type Person record as the Record Label, then press Enter.

3. Type PERSON_RECORD as the Record Name, then press Enter.

4. Press Enter to leave the Type Value as is.

5. Press N to change Required from Yes to No, then press Enter. Our application can have households with no people,
so person records are not required for us.

6. Our application can have up to 10 people in a household, so type 10, then Enter, to change Max and complete the
changes to this record.

Next we will add the Housing Record:
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1. Right-click on Person record on the tree on the left, then select Add Record.

2. Type Housing record as the Record Label, the press Enter.

3. Press Enter to accept HOUSING_RECORD as the Record Name.

4. Press Enter to leave the Type Value as is.

5. Press Enter to leave Required as Yes.

6. Press Enter to leave Max as 1 and start a new record.

7. Press Esc on the blank record to finish making these changes.

When you have completed this step the screen should look something like:

Continue to the next step: Step 3: Creating the Items.

Step 3: Creating the Items
(Exercise 2, Create the Data Dictionary)

First, we will create the items Age, Sex, and Marital status in the Person record.

1. Right-click on Person record on the tree, then select Add Item.

2. Enter Age as the Item Label, then press Enter.

3. Press Enter to accept AGE as the Item Name.

4. Press Enter to accept the Start position.
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5. Type 2 then Enter to indicate that Age takes up two characters. This is because in our application we have chosen to
enter ages only up to 99.

6. Press Enter six times to accept the rest of the default attributes for Age.

7. Enter the attributes for the Sex item. After you type in the label and name, you can keep pressing Enter to accept all
the other default attributes.

8. Enter the attributes for the Marital status item. After you type in the label and name, you can keep pressing Enter to
accept all the other default attributes.

9. Press Esc to finish creating the items.

Next, we will create the Type household and Type roof items in the Housing record.

1. Right-click on Housing record, then select Add Item.

2. Enter the attributes for the Type household item. After you type in the label and name, you can keep pressing Enter
to accept all the other default attributes.

3. Enter the attributes for the Type roof item. After you type in the label and name, you can keep pressing Enter to
accept all the other default attributes.

4. Press Esc to finish creating the items.

When you have completed this step the screen should look something like:

Continue to the next step: Step 4: Creating Values for the Items.

Step 4: Creating Values for the Items
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(Exercise 2, Create the Data Dictionary)

Value sets define what data values we expect for a data item. Value sets are used to define ranges of valid values during
data entry and to define categories for cross tabulation.

First we will create a value set for Age. We will use ten-year age groups.

1. Click on the + next to Person record to make sure its items are showing on the tree.

2. Right-click on Age and then select Add Value Set.

3. Press Enter twice to accept the default Value Set Label and Value Set Name. The cursor will drop to the line below
into the Value Label column.

4. Type 0 to 9 for the Value Label, then Enter.

5. Type 0 as the From value, then Enter.

6. Type 9 as the To value, then Enter twice, skipping over the Special column.

7. Type 10 to 19 for the next Value Label, then Enter.

8. Type 10 as the From value, then Enter.

9. Type 19 as the To value, then Enter twice, skipping over the Special column.

10. Continue in this fashion until you have reached 90 to 99.

Next, we will create a value set for Sex.

1. Right-click on Sex, then select Add Value Set.

2. Press Enter twice to accept the default Value Set Label and Value Set Name. The cursor will drop to the line below
into the Value Label column.

3. Type Male as the first Value Label.

4. Type 1 as the From value.

5. Press Enter twice to skip over the To and Special columns.

6. Type Female as the second Value Label.

7. Type 2 as the From value.

8. Press Enter twice to skip over the To and Special columns.

9. Press Esc to finish creating the value set.

To finish up:

1. Add a value set for Marital status. Use 1 for Married and 2 for Not married.

2. Add values for the Housing record items from the housing information in the questionnaire.

3. Save the work you have done so far: Select File -> Save from the main menu, or click on  on the toolbar.

When you completed this step, the screen might look something like:
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This completes this exercise. Continue to the next exercise: Step 1: Place ID and Housing Items on Form
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Exercise 3: Create the Data
Entry Forms

Step 1: Place ID and Housing Items on Form
(Exercise 3, Create the Data Entry Forms)

We will now switch from the data dictionary to the forms.

Generally it is a good idea to make the data entry forms look just like the questionnaire itself. We can easily do this in CSPro.
However, in order to show you more features and save time, we will not do so in this tutorial.

We will place the dictionary items on the data entry form.

1. Click  on the toolbar. A blank gray form will appear on the right hand side of the screen.

2. Make sure the items on the tree are expanded so you can see them all. If any item has a + sign next to it, click on the
+ sign.

3. Drag and drop MyDict identification from the tree to the top of the form. (Click on MyDict identification and hold
the mouse button down while you move the mouse to the top of the form, then release the mouse button.)

4. Drag and drop Housing record from the tree to the form, underneath MyDict identification. Click OK to accept the
Drag Options settings.

Next, we will line things up.

1. Multi-select the three pieces of text. Hold down the Ctrl key and click on MyDict identification, then click on Type
household, click on Type roof, then release the Ctrl key.

2. Select Align -> Left from the main menu.

3. Multi-select the three data entry boxes.

4. Select Align -> Right.

When you have completed this step the screen should look something like:
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Continue to the next step: Step 2: Add Text and Boxes.

Step 2: Add Text and Boxes
(Exercise 3, Create the Data Entry Forms)

First, we will add our own line of text at the top of the screen.

1. Right-click on the form, somewhere above MyDict identification.

2. Select Add Text from the menu.

3. Type My First Application and then Enter (or click on OK).

4. Adjust the position of the text until it is just where you want it. To do this, select the text (click on it) and use the
arrow keys, or drag and drop the text to the new location.

Next we will draw a box around the data entry fields.

1. Click  on the toolbar. A small toolbar will appear floating over the screen.

2. Click on the box second to the right of the floating toolbar.

3. Position the mouse pointer above and to the left of MyDict identification.

4. Left-click and hold the button down.

5. Drag the mouse toward the right and down.

6. When the box looks the way you want it, release the mouse button.
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7. Click  again on the toolbar to close the floating toolbar.

When you have completed this step the screen should look something like:

Continue to the next step: Step 3: Generate Forms Automatically.

Step 3: Generate Forms Automatically
(Exercise 3, Create the Data Entry Forms)

CSPro allows you to generate a complete set of forms, which include all the items in the data dictionary, in one operation.
We will use this feature now in order to save time.

1. Select Edit -> Generate Forms from the main menu, or press Ctrl+G.

2. CSPro will warn you that the forms you made in steps 1 and 2 will be replaced. Click on Yes to continue.

3. The Drag Options dialog box will appear. Make sure the Roster Options has Horizontal selected. Click on OK to
close the Drag Options dialog box.

4. Note that the tree on the left shows that you now have three forms. Open up the entire tree by clicking the + next to
any part of the tree.

5. Click on PERSON_RECORD_FORM on the tree. You will see the roster that CSPro created for you.

6. Click around on the tree on the left as you like to explore the forms that CSPro created.

7. Save the work you have done so far. Select File -> Save from the main menu, or click  on the toolbar.
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When you have completed this step the screen should look something like:

This completes this exercise. Continue to the next exercise: Step 1: Run the Data Entry Application.
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Exercise 4: Enter Data
Step 1: Run the Data Entry Application
(Exercise 4, Enter Data)

Your data entry application is now ready to run! CSEntry is the name of the program that runs this application, allowing you
to key in data.

1. Run CSEntry by clicking  on the toolbar, or pressing Ctrl+R. CSPro will ask you to save your work if you haven't
already done so. Click Yes.

2. CSEntry will ask you to select a data file. The data we key will go into this file. Change to the folder you created for
this set of exercises, C:\CSProTutorial. Type MyData.dat for the file name, then press Enter.

3. CSEntry will ask if you want to create a new file. Click Yes.

4. CSEntry will ask for your Operator ID. You may type in anything you like.

5. The first data entry form will appear with the cursor ready for you to begin entering data.

When you have completed this step the screen should look something like:

Continue to the next step: Step 2: Add a Case.
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Step 2: Add a Case
(Exercise 4, Enter Data)

We will now type in the data for our first case (questionnaire). We will use a fictitious family of four.

1. Type 1 then Enter to fill in the ID item. The next form will appear, showing the person roster.

2. Type 48 in the Age field. The cursor will move to the Sex field.

3. Type 3 in the Sex field. CSEntry will tell you this value is out of range, because it is not in the value set for Sex you
created in your data dictionary.

4. With the OUT OF RANGE message still showing, type 1. The message will go away and the cursor will move to the
Marital status field.

5. Continue typing in data for the family as shown below.

Some CSEntry tips:

You can move backward to the previous field using Shift+Tab, left arrow or up arrow.

You can move forward to the next field using Enter, Tab, right arrow or down arrow.

You can change a field by simply typing a new number into it.

You can erase a field using the space bar.

Continue to the next step: Step 3: Finish Adding a Case.
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Step 3: Finish Adding a Case
(Exercise 4, Enter Data)

We will now tell the roster that we have finished entering people.

1. Hold down the Ctrl key.

2. Press the slash key / (on the numeric keypad). The next form will appear on the screen. If you have trouble finding this
key combination, which could be the case on some laptops, you can select Navigation -> End Group from the main
menu.

Next we will type in the household form and end the case.

1. Type 1 in the Type household field.

2. Type 1 in the Type roof field.

3. CSEntry will ask us to accept the case. At this point you can select No and go back and make changes to the data in
the case if you like. If you are satisfied that the data are correct, press Enter or select Yes.

4. CSEntry will now show the first form again, with the cursor ready for you to type in another case. We will now stop
adding cases. Click  on the toolbar, or press Esc or Ctrl+S, or select Mode -> Stop from the main menu.

When you have completed this step the screen should look something like:

Continue to the next step: Step 4: Modify a Case.
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Step 4: Modify a Case
(Exercise 4, Enter Data)

Now we realize that the first person in the household is really 45-years-old and not 48 as we typed in. We will go back into
the data and change this value.

1. Click on  on the toolbar, or press Ctrl+M to enter Modify mode. You should see the first form, with the value 1
showing for MyDict identification.

2. Press the PgDn key to advance to the next form.

3. Type 45 in the Age field.

4. Press F12 to indicate that you have finished making your changes.

5. The screen will now look something like the picture below. CSEntry will ask you to accept the case, like it did in the
previous step. Select Yes.

6. CSEntry will save your changes and exit from Modify mode.

7. Close CSEntry by clicking on the X in the top right corner, or selecting File -> Exit from the main menu.

This completes this exercise. Continue to the next exercise: Step 1: Create a Tabulation Application.
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Exercise 5: Tabulate Data
Step 1: Create a Tabulation Application
(Exercise 5, Tabulate Data)

In this exercise we will perform simple cross tabulations of the data you entered in the previous exercise.

If you still have your data entry application open from previous exercises, close it now. Select File -> Close from the main
menu. CSPro may prompt you to save changes. Select Yes.

We will now create a cross tabulation application using the Wizard, as we did previously.

1. Select File -> New from the main menu, or click  on the toolbar.

2. Select Tabulation Application and press OK.

3. In the file open dialog box, enter MyTab as the file name for the application.

4. Make sure you are located in the folder you created for these exercises (C:\CSProTutorial).

5. Press Save.

6. The next screen will ask you to select the Input Dictionary.

7. Change the name to C:\CSProTutorial\MyDict.dcf.

8. Press OK.

You are now ready to begin designing your tabulation.

When you have completed this step the screen should look something like:
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Continue to the next step: Step 2: Select Items to Tabulate.

Step 2: Select Items to Tabulate
(Exercise 5, Tabulate Data)

We will create a tabulation of Age by Sex. Age will appear as the rows and Sex as the columns.

1. Click on the + next to Person record to make sure its items are showing on the tree.

2. Drag and drop Age from the tree to the left side of the table. (Click on Age and hold the mouse button down while
you move the mouse to the side of the table then release the mouse button.) The drop point should be in the white
space next to one of the gray boxes along the side.

3. Drag and drop Sex from the tree to the top of the table. (Click on Sex and hold the mouse button down while you
move the mouse to the top of the table then release the mouse button.) The drop point should be in the white space
just under one of the gray boxes along the top.

Tips for creating tabulations:

The item you drag from the dictionary tree will become either a row item or a column item depending on where you
drop it. Imagine a diagonal line from the top left to the bottom right of the table. An item dropped on the left/under
that line becomes a row item. An item dropped on the right/above that line becomes a column item.

You can remove an item from the table by clicking on any of its associated labels then dragging and dropping it back
to the dictionary tree.

When you have completed this step the screen should look something like:
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Continue to the next step: Step 3: Run the Tabulation.

Step 3: Run the Tabulation
(Exercise 5, Tabulate Data)

We are now ready to run the tabulation. We will use the data file you created in the previous exercise.

1. Run the tabulation by clicking on  on the toolbar, or pressing Ctrl+R. If CSPro prompts you to save the changes,
click on Yes.

2. CSPro will ask you for the data file(s) to tabulate. Select MyData.dat. Make sure the dialog box is set to the folder you
created for these exercises, C:\CSProTutorial.

3. The tabulated numbers will now appear in the table. That's all there is to it!

When you have completed this step the screen should look something like:
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This completes this exercise. Continue to the next exercise: Step 1: Add Percents.
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Exercise 6: Modify the Table
Step 1: Add Percents
(Exercise 6, Modify the Table)

In this exercise we will modify the table you created in the previous exercise. We will begin by adding percents to the
columns next to the values for the Sex variable.

1. Right-click on the word Sex on the table, just above the word Male.

2. Select Tally Attributes (Sex) from the right-click menu.

3. In the list on the left of the dialog box marked Available, click on Percents and then click the Add --> button. You
should now see Percents listed in the list on right of the dialog box marked Selected.

4. Click OK. You should see three new columns on the table for the percents.

5. Run the tabulation by clicking  on the toolbar, or pressing Ctrl+R. When CSPro prompts you to save the changes,
click on Yes.

6. Select MyData.dat as the data file to tabulate, as in the previous exercise.

When you have completed this step you should see a table that looks something like:
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Continue to the next step: Step 2: Add a Universe.

Step 2: Add a Universe
(Exercise 6, Modify the Table)

We will now add a universe to our table. A universe is a filter, or a way of restricting the table to a subset of the data records
that meet a certain condition. In this step we will run the table for married people.
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1. Right-click anywhere on the table.

2. Select Tally Attributes (Table) from the right-click menu.

3. In the section of the dialog box marked Universe, type MARITAL_STATUS = 1. Be sure to type this correctly,
otherwise you may see the message "Invalid Universe Syntax."

4. Click OK.

5. Run the tabulation by clicking  on the toolbar, or pressing Ctrl+R. When CSPro prompts you to save the changes,
click on Yes.

6. Select MyData.dat as the data file to tabulate, as in the previous exercise.

When you have completed this step you should see a table that looks something like the following. Notice that the counts
are lower than in the previous step because we are not counting unmarried people.
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Continue to the next step: Step 3: Change the Title Font.

Step 3: Change the Title Font
(Exercise 6, Modify the Table)

CSPro gives you great control over the format of your tables. As an example, in this step we will change the font of our
table's title to make it bigger.
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1. Right-click on the title Table 1. Age by Sex at the top of the table.

2. Select Format (Title) from the right-click menu.

3. In the section of the dialog box marked Font and Color click on the Change button.

4. In the Font dialog box that appears, change the Size from 12 to 16.

5. Click OK to close the Font dialog box.

6. Click OK to close the Format (Title) dialog box.

When you have completed this step you should see that the title is now larger.

This completes this exercise. Continue to the next exercise: Step 1: Write Logic for the Edit.
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Exercise 7: Add Edits to the
Data Entry Application

Step 1: Write Logic for the Edit
(Exercise 7, Add Edits to the Data Entry Application)

We will now return to the data entry application. We will introduce a check to make sure that married people are at least
12-years-old. In our data entry application, we will perform this check immediately after the keyer enters the marital status.

If you still have your cross tabulation application open from previous exercises, close it now. Select File -> Close from the
main menu. CSPro may prompt you to save changes. Select Yes.

1. Open the data entry application we created earlier. Click on  on the toolbar, or select File -> Open from the main
menu. Click on the application name, MyEntry.ent, and click Open.

2. Get ready to write logic by clicking  on the toolbar, or pressing Ctrl+L or selecting View -> Logic from the main
menu.

3. Press Ctrl+T to show names instead of labels in the forms tree.

4. Click on the + next to PERSON_RECORD_FORM then click on the + next to PERSON_RECORD000 then click on
MARITAL_STATUS. The frame on the right hand side of the screen should show PROC MARITAL_STATUS at the
top.

5. Note that PROC is short for procedure. We put our logic in the procedure for MARITAL_STATUS because we want it
to execute immediately after the operator keys this field.

6. Type in the logic code exactly as you see below.

PROC MARITAL_STATUS

    if MARITAL_STATUS = 1 and AGE < 12 then
        errmsg("Too young to be married");
    endif;
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Continue to the next step: Step 2: Compile the Logic.

Step 2: Compile the Logic
(Exercise 7, Add Edits to the Data Entry Application)

You have typed logic in the CSPro language. Like all procedural languages, the system must check to make sure that there
are no syntax errors. This is called compiling.

1. Click on MYDICT_FF in the forms tree to show all the CSPro logic.

2. Compile the logic by clicking  on the toolbar, or pressing Ctrl+K or selecting File -> Compile from the main menu.

3. If you typed the logic correctly, you will see Compile Successful in the Compiler Output window under the logic.

4. If you see a dialog box that says Compile Failed, you have typed something incorrectly. A red circle will appear in the
margin indicating the approximate location of the error. The Compiler Output tab at the bottom of the screen will
show you an error message to help you determine the error. Check very carefully to make sure you typed in exactly
what was shown in the previous step.

When you have completed this step the screen should look something like:
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Continue to the next step: Step 3: Test the Edit.

Step 3: Test the Edit
(Exercise 7, Add Edits to the Data Entry Application)

We are now ready to run the data application and make sure our logic is working properly.

1. Run CSEntry by clicking  on the toolbar, or pressing Ctrl+R.

2. CSPro will ask you to save the changes. Click Yes.

3. CSEntry will ask you to select a data file. Type MyData.dat for the file name, if it is not already there, then press OK.

4. Type in any Operator ID.

5. Click on  on the toolbar, or press Ctrl+A to enter Add mode. The first form will appear with the cursor on MyDict
identification.

6. Type 2 and then Enter to fill in the ID item. The next form will appear, showing the person roster.

7. Type 10 in the Age field.

8. Type 1 in the Sex field.

9. Type 1 in the Marital status field.

Your error message should appear on the screen as shown below.
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Continue to the next step: Step 4: Complete the Case.

Step 4: Complete the Case
(Exercise 7, Add Edits to the Data Entry Application)

We will finish entering data for the second case, including the error condition, so that we will be able to test that condition in
the following exercise.

1. Press F8 to clear the message.

2. Hold down the Ctrl key and press the slash key / on the numeric keypad. The next form will appear on the screen.

3. Type 1 in the Type household field.

4. Type 1 in the Type roof field.

5. CSEntry will ask us to accept the case. Select Yes.

6. Click  on the toolbar, or press Esc or Ctrl+S, or select Mode -> Stop from the main menu.

7. Close CSEntry by clicking on the X in the top right corner, or selecting File -> Exit from the main menu.

This completes this exercise. Continue to the next exercise: Step 1: Create a Batch Application.
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Exercise 8: Run a Batch
Application

Step 1: Create a Batch Application
(Exercise 8, Run a Batch Application)

In the previous exercise we wrote logic to perform an edit interactively, i.e. at the time of data entry. In this exercise we will
apply the same logic in a batch application, i.e. after data entry. Our logic will check the data and produce a report telling us
about any errors.

If you still have your data entry application open from previous exercises, close it now. Select File -> Close from the main
menu. CSPro may prompt you to save changes. Select Yes.

We will now create a batch application using the Wizard, as we did previously.

1. Select File -> New from the main menu, or click  on the toolbar.

2. Select Batch Edit Application and press OK.

3. In the file open dialog box, enter MyBatch as the file name for the application.

4. Make sure you are located in the folder you created for these exercises (C:\CSProTutorial).

5. Press Save.

6. The next screen will ask you to select the Input Dictionary.

7. Change the name to C:\CSProTutorial\MyDict.dcf.

8. Press OK.

You are now ready to begin designing your batch edit application.
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When you have completed this step the screen should look something like:

Continue to the next step: Step 2: Write Logic and Compile.

Step 2: Write Logic and Compile
(Exercise 8, Run a Batch Application)

We will write the same logic we used in the previous exercise.

Press Ctrl+T to show names instead of labels in the edits tree.

Click on the + next to PERSON_RECORD_EDT then click on MARITAL_STATUS. The frame on the right hand side of the
screen should show PROC MARITAL_STATUS at the top.

Type in the logic exactly as you see below.

Note that we used $ in place of MARITAL_STATUS. This is the same thing because the logic is inside the procedure for
MARITAL_STATUS. In the CSPro language, $ is a short way of saying "this item."

Compile the logic by clicking  on the toolbar, or pressing Ctrl+K or selecting File -> Compile from the main menu.

Correct any errors until you see Compile Successful.

PROC MARITAL_STATUS

    if $ = 1 and AGE < 12 then
        errmsg("Too young to be married");
    endif;
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Continue to the next step: Step 3: Run the Batch Application.

Step 3: Run the Batch Application
(Exercise 8, Run a Batch Application)

Your batch application is now ready to run. CSBatch is the name of the program that runs this application. We will use the
data file you created in the previous exercise.

1. Run CSBatch by clicking  on the toolbar, or pressing Ctrl+R.

2. CSPro will ask you to save the changes. Click Yes.

3. CSBatch will ask for some data file names. Click in the empty box next to Input Data File and type in MyData.dat and
click OK.
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CSBatch will now run your program.

Continue to the next step: Step 4: Examine the Output Report.

Step 4: Examine the Output Report
(Exercise 8, Run a Batch Application)

The output report will appear in the CSPro Text Viewer. It will look something like:

Application     C:\CSProTutorial\MyBatch.bch
Type            BATCH
Input Data      <<Text File>> C:\CSProTutorial\MyData.dat
<Output>        <<Empty>>

Date            Jun 5, 2020
Start Time      07:11:00
End Time        07:11:00

CSPRO Process Summary
         +-----------------------------------------------------+
         |       7 Records Read ( 100% of input file)          |
         |       0 Ignored (       0 unknown,        0 erased) |
         |       1 Messages (       1 U,       0 W,       0 E) |
         +---------+--------------+--------------+-------------+
         |  Level  |  Input Case  |  Bad Struct  |  Level Post |
         +---------+--------------+--------------+-------------+
         |     1   |          2   |          0   |          2  |
         +---------+--------------+--------------+-------------+

Process Messages

*** Case [   2] has 1 messages (0 E / 0 W / 1U)
   U    -9 Too young to be married

User unnumbered messages:

  Line    Freq  Pct.  Message text                                        Denom
  ----    ----  ----  ------------                                        -----
     9       1    -   Too young to be married                                 -

CSPRO Executor Normal End
--------------------------------------------------------------------------------
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The first several lines show file names and the date and time of the run.

CSPro Process Summary

The first line tells us that the data file had seven records.

The second line tells us that there were no problems with the structure of the data file.

The third line tells us that one user message was triggered by our logic. The system did not issue any warning or
error messages.

The last line tells us that our data file has two cases in it.

Process Messages

This section shows messages by case by case. In our example we only triggered one message, so only one case is shown. Case
[   2] shows us the case ID; in this example the second case has the error.

User Unnumbered Messages

This section shows a summary by message, Since we have only errmsg command in our logic, there is only one line. The
number 9 under Line tells us the line number of the errmsg command in our logic. The number 1 under Freq tells us that
this message was only triggered once for the data file.

Conclusion

When you have finished examining the report, close Text Viewer by pressing Esc or selecting File -> Exit from the main menu.

Congratulations! You have completed the CSPro tutorial. We hope you are now ready to try creating and running your own
applications. Please refer to our User's Guides for more details. You can access them from CSPro simply by selecting Help ->
Help Topics from the main menu of any CSPro module.
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