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CSPro Getting Started Guide

Introduction

What is CSPro?

The Census and Survey Processing System (CSPro) is a software package for entry, editing, tabulation, and dissemination of
census and survey data. CSPro combines the features of the Integrated Microcomputer Processing System (IMPS) and the
Integrated System for Survey Analysis (ISSA).

CSPro lets you create, modify, and run data entry, batch editing, and tabulation applications in a single, integrated
development environment. It processes data on a case basis (one or more questionnaires), where a case can consist of one
or many data records. The data are stored in files described by data dictionaries. CSPro contains a powerful common
procedure language to implement data entry control and edit rules.

CSPro also provides tools to view data and other text files, to view tables created by CSPro, and to convert IMPS and ISSA
data dictionaries to and from CSPro.

CSPro was developed jointly by the U.S. Census Bureau, ICF International, and Serpro, S.A., with major funding from the U.S.
Agency for International Development.

CSProis in the public domain. It is available at no cost and may be freely distributed. It is available for download at
WWW.census.gov/data/software/cspro.html.

This guide contains information about installing and uninstalling CSPro, followed by a tutorial that will guide you through a
series of exercises to help you get started using CSPro.

CSPro Features

This is an overview of some of CSPro's main capabilities. You can also view information about CSPro's tools.
Data Entry

Add, modify, verify and view cases (questionnaires). Create an unlimited number of forms (screens). Create forms bigger
than the computer screen that scroll as necessary. Create forms with fields from different physical records. Enter data from
rosters. Create consistency checks and skip patterns of unlimited complexity. Execute procedures before and/or after field is
entered. Display user-defined messages. Access multiple lookup files. Read from and write to secondary files. Index cases to
avoid duplication. Produce operator statistics. Create a stand-alone data entry environment.

Batch Editing

Identify and report structure, value, and consistency errors in questionnaire data. Change (impute) data values based on
simple or complex methods. Produce summary or detailed reports of errors and corrections. Access multiple lookup files.
Read from and write to secondary files.

Tabulation
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Define and select variables to tabulate. Select the universe of tabulation. Tabulate values and weights. Format tabulations
for viewing or printing. Save tabulations in several formats. Copy tables to spreadsheets or word-processing documents.
Produce tables by geographic area.

Data Dictionary

Define simple or complex hierarchical file organization. Define hierarchical levels, identification items, records, items (fields
or variables), value sets (categories of values), and values. Create descriptive notes for documentation. Define multiply
occurring items and define relationships between multiply occurring records and items. Produce reports of file organization.
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Installation

Hardware and Software Requirements

The minimal configuration for CSPro is:

e Pentium processor

e 512MB of RAM

e SVGA monitor

¢ Mouse

e 100MB of free hard drive space

e Microsoft Windows Vista, 7, 8, or 10

Installing CSPro

The CSPro installer has the file name cspro75.exe. To install CSPro:

1. Double-click on the file.
2. Read and accept the U.S. Census Bureau's license agreement
3. Select the components that you want to install. You will generally want to install all of the components.

4. Select the folder where you want to install CSPro. You will generally want to install CSPro in the suggested directory.
After CSPro has been installed on your computer, you will have the option to run the program and/or view the release notes.

You will find a CSPro 7.5 icon on your desktop that you can double-click on when you want to run CSPro in the future.

Installing a Newer Version

Upgrading to CSPro 7.5 From CSPro 7.4 or Earlier

If you have an old version of CSPro installed on your computer, you can install CSPro 7.5 without affecting the previous
version. When you have finished your conversion of applications to CSPro 7.0, you can then uninstall the previous version.

Due to internal changes within CSPro 7.5, once files have been loaded in CSPro 7.5, you may no longer be able to load them
in previous versions of CSPro.

Updating a Previous Version of CSPro 7.5

If you are updating a previous version of CSPro 7.5, the installer will remove the previous version and replace it with the new
version. It will not change any applications or other files that you have created.

Uninstalling CSPro

There are two ways to uninstall CSPro. The uninstaller will remove all registry entries and CSPro system files. It will not
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remove any applications or other files that you have created.
You can uninstall the program using the Windows Control Panel:

1. Using the Windows search functionality (Windows Key+S), type Add or remove programs.
2. Select CSPro from the list of programs.

3. Follow the prompts to uninstall the program.
Alternatively, you can:

1. Use Windows Explorer to browse to the CSPro application folder, which will likely be: C:\Program Files (x86)\CSPro
7.5.

2. Run the program uninstall.exe.

3. Follow the prompts to uninstall the program.
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CSPro Tutorial

About the Tutorial

The tutorial will guide you through a series of exercises to help you get started using CSPro.

The exercises in the tutorial require no special knowledge other than basic familiarity with Windows. The exercises are
divided into very short steps. Each step normally takes only a few minutes.

There are eight exercises. You will files in each exercise that are used in later exercises. Exercises 1 through 6 show you
simple data entry and cross tabulation. Exercises 7 and 8 show you the CSPro language for editing.

1. Create a Data Entry Application (3 steps)

2. Create the Data Dictionary (4 steps)

3. Create the Data Entry Forms (3 steps)

4. Enter Data (4 steps)
5. Tabulate Data (3 steps)

6. Modify the Table (3 steps)

7. Add Edits to the Data Entry Application (4 steps)

8. Runa Batch Application (4 steps)
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Exercise 1: Create a Data
Entry Application

Step 1: Examine the Tutorial Questionnaire

(Exercise 1, Create a Data Entry Application)

The tutorial exercises are based on a sample questionnaire. In Exercises 1 through 6 we will create a data entry application,
key some data, then tabulate the data. In Exercises 7 and 8 we go back and add a consistency check.

Household |D CSPRO TUTORIAL
| QUESTIONNAIRE

ALl PERSONS
Age oeX Marital Status

1-Male 1 - Married
2-Female |2 - Mot married

| D OO A S | L R —

ety

HOUSEHOLD INFORMATION

Type Housing Type Roof |

1 - Single family 1 - Wood
2 - Multi-family 2 - Metal
3 - Homeless 3 - Other

Note the following about the sample questionnaire:

Each questionnaire corresponds to a household.

Each questionnaire (household) has a unique four-digit number at the top.

We collect age, sex, and marital status for up to ten people in the household.

We collect type of housing and roof for the household.

Continue to the next step: Step 2: Start CSPro.
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Step 2: Start CSPro

(Exercise 1, Create a Data Entry Application)

First, create a new folder for all files you will use in this tutorial. Open Windows Explorer and create a folder named
C:\CSProTutorial.

Now you are ready to start CSPro, which you can by double-clicking on the CSPro 7.5 icon on your desktop, or by finding the
proper link off the Start menu.

The CSPro main screen will appear:

Q& CsPro - O ¥
File Tpale— bl
T = 4 Start CSPro =
0=
D ™ Create a new application
T
D ¥ Open an existing application
... other files
QK I Cancel Help |
For Help, press F1 | | INUM | |

Continue to the next step: Step 3: Naming Application Files.

Step 3: Naming Application Files

(Exercise 1, Create a Data Entry Application)

We will create a data entry application. This contains:

e Data dictionary: The data dictionary describes the organization of the data file. It holds information about all the
questions and responses on the questionnaire.

e Forms: The forms will appear on the screen when you run the data entry application. They contain data entry fields,
text, and rosters.
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e |ogic (optional): You can use the CSPro language to control the flow of your program, to write logic to check for
errors during data entry, to access lookup files, and many other things. We will not use logic until Exercise 6.

We will use the Wizard to create the files that the data entry application requires. Click on the radio button that says Create
a new application. You should see the following dialog box:

Mew >

Application l Other ]

Application Type:

C5SPro applications process data
from surveys and censuses. All the
files necessary for an application

‘,. CAPI Data Entry Application | can be specfied when the
application is created.

/ Batch Edit Application

) . Chooze Data Entry Application to
@ Tabulation Application keery from paper; select CAF| Data

Entry Application to conduct a
computer assisted personal
interview using a phone, tablet, or
laptop.

] | Cancel Help

1. Select Data Entry Application and press OK.

2. Inthe file open dialog box, enter MyEntry as the file name for the application.

3. Make sure you are located in the folder you created for these exercises (C:\CSProTutorial).
4. Press Save.

5. The next screen will ask you to select the Input Dictionary.

6. Change the name to C:\CSProTutorial\MyDict.dcf.

7. Press OK.

8. CSPro will ask if you want to create a new dictionary. Press Yes.
You have created a new data entry application

This completes this exercise. Continue to the next exercise: Step 1: The ID Item.
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Exercise 2: Create the Data
Dictionary

Step 1: The ID Item

(Exercise 2, Create the Data Dictionary)

We will make our dictionary first, then our forms. CSPro automatically generates a skeleton data dictionary. We will change
it and add our own information.

Every data dictionary requires at least one |D item, and you will often have more than one. An ID (identification) item is a
unique number (or series of numbers) that allows CSPro to distinguish between individual questionnaires. CSPro requires at
least one ID item.

1. Click on (Id Items), then on the '+' next to it to open the tree on the left side of the screen. You will see that CSPro has
created one ID item. On the right side of the screen you will see in the Len column that this item has the length of
one character. We will make this four characters.

2. Right-click on MyDict identification, below (Id Items) on the tree, and then select Modify Item.
3. Pressthe Enter key three times until the length is highlighted in blue.

4. Type 4 and then Enter, then click on the white space below this line to finish making this change.

When you have completed this step the screen should look something like:
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& CSPro - [MyDict.dcf] — O e
@ File Edit View Options Tools Window Help - &
IDFEO0RE | s BRE X BMAE ST T P
L | ltem Label | ltem MName | Start| Len | Data Type| ltem Type
-4 MyDict (record type) 1 1 Alpha
E!!. MyDict questionnaire |:| M"_yl'Dlﬂt identification MYD'CT_'D 2 4 Mum
- (Id kems)
i M MyDict idertfication
‘._mm MyDict record
RS Uik LM || | | |
For Help, press F1 |F‘.elati1.re Positions | | | |

Continue to the next step: Step 2: The Records.

Step 2: The Records

(Exercise 2, Create the Data Dictionary)

A record usually corresponds to a section of a questionnaire and consists of a group of related questions.

By default, CSPro creates one record. Our tutorial application will have two records, a Person Record and a Housing
Record. We will change the one record that CSPro generated to Person Record, and then add the Housing Record.

First, we will change the one record that CSPro generated to Person Record:

1. Right-click on MyDict record on the tree on the left, then select Modify Record.

2. Type Person record as the Record Label, then press Enter.
3. Type PERSON_RECORD as the Record Name, then press Enter.

4. Press Enter to leave the Type Value asiis.

5. Press N to change Required from Yes to No, then press Enter. Our application can have households with no people,

so person records are not required for us.

6. Our application can have up to 10 people in a household, so type 10, then Enter, to change Max and complete the

changes to this record.

Next we will add the Housing Record:
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1. Right-click on Person record on the tree on the left, then select Add Record.
2. Type Housing record as the Record Label, the press Enter.

3. Press Enter to accept HOUSING_RECORD as the Record Name.

4. Press Enter to leave the Type Value as is.

5. Press Enter to leave Required as Yes.

6. Press Enter to leave Max as 1 and start a new record.

7. Press Esc on the blank record to finish making these changes.

When you have completed this step the screen should look something like:

& CSPro - [MyDict.dcf *] - | e
@ File Edit View Options Tools Window Help - &
D ORE | édBR|E =X EME ST ?
‘|| N | Record Label | Record Name | Type Value | Required| Max
=4 MyDict [ Person record PERSON_RECORD 1 Mo 10
El'!!. MyDict questionnaire | Housing record  HOUSING RECORD 2 Yes 1
G-m (Id tems)
- mm Person record
‘. mm Housing record
£ FIES EDESIEF BT
For Help, press F1 Relative Positions | | | |

Continue to the next step: Step 3: Creating the Items.

Step 3: Creating the Items

(Exercise 2, Create the Data Dictionary)

First, we will create the items Age, Sex, and Marital status in the Person record.

1. Right-click on Person record on the tree, then select Add Item.
2. Enter Age as the Item Label, then press Enter.
3. Press Enter to accept AGE as the Item Name.

4. Press Enter to accept the Start position.
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5. Type 2 then Enter to indicate that Age takes up two characters. This is because in our application we have chosen to
enter ages only up to 99.

6. Press Enter six times to accept the rest of the default attributes for Age.

7. Enter the attributes for the Sex item. After you type in the label and name, you can keep pressing Enter to accept all
the other default attributes.

8. Enter the attributes for the Marital status item. After you type in the label and name, you can keep pressing Enter to
accept all the other default attributes.

9. Press Esc to finish creating the items.
Next, we will create the Type household and Type roof items in the Housing record.

1. Right-click on Housing record, then select Add Item.

2. Enter the attributes for the Type household item. After you type in the label and name, you can keep pressing Enter
to accept all the other default attributes.

3. Enter the attributes for the Type roof item. After you type in the label and name, you can keep pressing Enter to
accept all the other default attributes.

4. Press Esc to finish creating the items.

When you have completed this step the screen should look something like:

& CSPro - [MyDict.dcf] - O x
@n Eile Edit View Options Toocls Window Help - &
DeEIRE « >~ | $BRBRE XM E I 2
N | ltem Label | ltem MName | Startl Len | Data Type ltem Type
-4 MyDict (record type) 1 1 Alpha
El!!. MyDict questionnaire | MyDict identification MYDICT _|D 2 4 Mum [tem
G2 (Id ems) O Type household TYPE HOUS 6 1 Num ltem
[-—mm Person record
: 8]
- M| Type roof TYPE_ROOF 7 1 Mum
----- M Type household
...... (] Twe muf
PR Y ) p— Y I |
For Help, press F1 |Relative Positions | |NUM | |

Continue to the next step: Step 4: Creating Values for the [tems.

Step 4: Creating Values for the Items
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(Exercise 2, Create the Data Dictionary)

Value sets define what data values we expect for a data item. Value sets are used to define ranges of valid values during
data entry and to define categories for cross tabulation.

First we will create a value set for Age. We will use ten-year age groups.

1. Click onthe + next to Person record to make sure its items are showing on the tree.
2. Right-click on Age and then select Add Value Set.

3. Press Enter twice to accept the default Value Set Label and Value Set Name. The cursor will drop to the line below
into the Value Label column.

4. Type 0 to 9 for the Value Label, then Enter.

5. Type 0 as the From value, then Enter.

6. Type 9 asthe To value, then Enter twice, skipping over the Special column.
7. Type 10 to 19 for the next Value Label, then Enter.

8. Type 10 as the From value, then Enter.

9. Type 19 as the To value, then Enter twice, skipping over the Special column.

10. Continue in this fashion until you have reached 90 to 99.
Next, we will create a value set for Sex.

1. Right-click on Sex, then select Add Value Set.

2. Press Enter twice to accept the default Value Set Label and Value Set Name. The cursor will drop to the line below
into the Value Label column.

3. Type Male as the first Value Label.

4. Type 1 asthe From value.

5. Press Enter twice to skip over the To and Special columns.
Type Female as the second Value Label.

Type 2 as the From value.

Press Enter twice to skip over the To and Special columns.

w ® N D

Press Esc to finish creating the value set.
To finish up:

1. Add a value set for Marital status. Use 1 for Married and 2 for Not married.
2. Add values for the Housing record items from the housing information in the questionnaire.

3. Save the work you have done so far: Select File -> Save from the main menu, or click on & on the toolbar.

When you completed this step, the screen might look something like:
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& CSPro - [MyDict.dcf] — O e
@ File Edit View Options Tools Window Help - &
DEEORE «~ ~|dB2RE X BME ST P
S| M| Value Set Label | Walue Set Name |‘u’alue Label | mel
-4 MyDict | Type roof TYPE_ROOF V51
El!!. MyDict questionnaire g Wood 1
-2 {id kems) O Metal 2
o Foron oo
El_- Housing record Ol Other 3
-~ Type housshold
...... W@ Type roof
=TS %% Dicts [[JF_Foms | 1 | | _’[

For Help, press F1

Relative Positions | | | |

This completes this exercise. Continue to the next exercise: Step 1: Place ID and Housing Items on Form
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Exercise 3: Create the Data
Entry Forms

Step 1: Place ID and Housing Items on Form

(Exercise 3, Create the Data Entry Forms)
We will now switch from the data dictionary to the forms.

Generally it is a good idea to make the data entry forms look just like the questionnaire itself. We can easily do this in CSPro.
However, in order to show you more features and save time, we will not do so in this tutorial.

We will place the dictionary items on the data entry form.

1. Clicklﬁ| on the toolbar. A blank gray form will appear on the right hand side of the screen.

2. Make sure the items on the tree are expanded so you can see them all. If any item has a + sign next to it, click on the
+ sign.

3. Drag and drop MyDict identification from the tree to the top of the form. (Click on MyDict identification and hold
the mouse button down while you move the mouse to the top of the form, then release the mouse button.)

4. Drag and drop Housing record from the tree to the form, underneath MyDict identification. Click OK to accept the
Drag Options settings.
Next, we will line things up.
1. Multi-select the three pieces of text. Hold down the Ctrl key and click on MyDict identification, then click on Type
household, click on Type roof, then release the Ctrl key.
2. Select Align -> Left from the main menu.
3. Multi-select the three data entry boxes.

4. Select Align -> Right.

When you have completed this step the screen should look something like:
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& CSPro - [MyEntry.frnf] — O Y
ﬂ File Edit View Options Align CAPl Opticns Tools Window Help - &
DS E 8o~ %8 HEEE| e ?
=4 MyDict
El!!. MyDict questionnaire
== {Id kems)
. L. MyDict identification
5}-_mm Person record MyDict identification [ | ]
El_- Housing record
-~ Type household
...... m T of
e Type household |:|
Type roof |:|
= Icts

9,123

Continue to the next step: Step 2: Add Text and Boxes.

Step 2: Add Text and Boxes

(Exercise 3, Create the Data Entry Forms)
First, we will add our own line of text at the top of the screen.

1. Right-click on the form, somewhere above MyDict identification.

2. Select Add Text from the menu.

3. Type My First Application and then Enter (or click on OK).

4. Adjust the position of the text until it is just where you want it. To do this, select the text (click on it) and use the
arrow keys, or drag and drop the text to the new location.

Next we will draw a box around the data entry fields.

1. Click i on the toolbar. A small toolbar will appear floating over the screen.
2. Click on the box second to the right of the floating toolbar.

3. Position the mouse pointer above and to the left of MyDict identification.
4. Left-click and hold the button down.

5. Drag the mouse toward the right and down.

6. When the box looks the way you want it, release the mouse button.
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7. Click & again on the toolbar to close the floating toolbar.

When you have completed this step the screen should look something like:

& C5Pro - [MyEntry.fmf] — O X
ﬂ File Edit Yiew Options Align CAPl Opticns  Tools Window Help - &
O = L e & ZE == * ?
=4y WyDict My First Application
El!!_ MyDict questionnaire
=-a {id kems)
© i..m MyDict identification
4]-mm Person record MyDict identification [ |
El_- Housing record
-~@ Type household
...... m T of
ypem Type household |:|
Type roof |:|
= icts
102,75 ML

Continue to the next step: Step 3: Generate Forms Automatically.

Step 3: Generate Forms Automatically

(Exercise 3, Create the Data Entry Forms)

CSPro allows you to generate a complete set of forms, which include all the items in the data dictionary, in one operation.
We will use this feature now in order to save time.

1. Select Edit -> Generate Forms from the main menu, or press Ctrl+G.

2. CSPro will warn you that the forms you made in steps 1 and 2 will be replaced. Click on Yes to continue.

3. The Drag Options dialog box will appear. Make sure the Roster Options has Horizontal selected. Click on OK to
close the Drag Options dialog box.

4. Note that the tree on the left shows that you now have three forms. Open up the entire tree by clicking the + next to
any part of the tree.

5. Click on PERSON_RECORD_FORM on the tree. You will see the roster that CSPro created for you.

6. Click around on the tree on the left as you like to explore the forms that CSPro created.

7. Save the work you have done so far. Select File -> Save from the main menu, or click = on the toolbar.
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When you have completed this step the screen should look something like:

& CSPro - [MyEntry.fmf] _ - %
(P Fle Edit View Options Align CAPIOptions Tools Window Help nr
LIRS ISR EEEE| e ?
= MYDICT_FF _
=- 'E!_MYDICT QUEST Age| Sex| Marital status
=0 IDSO_FORM

—

. l.m MYDICT_ID
-0 PERSON_RECORD_FORM
-0 HOUSING_RECORD_FORM

LT =T = - A = r I I — I FL R 8

I TEDETE DD ]

N} N | O
N O

-
[=]

_“\'_FI'IWJE’[S I"_-I_I.I Foms |

397,149

This completes this exercise. Continue to the next exercise: Step 1: Run the Data Entry Application.
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Exercise 4: Enter Data

Step 1: Run the Data Entry Application

(Exercise 4, Enter Data)

Your data entry application is now ready to run! CSEntry is the name of the program that runs this application, allowing you
to key in data.

1. Run CSEntry by clicking T onthe toolbar, or pressing Ctrl+R. CSPro will ask you to save your work if you haven't
already done so. Click Yes.

2. CSEntry will ask you to select a data file. The data we key will go into this file. Change to the folder you created for
this set of exercises, C:\CSProTutorial. Type MyData.dat for the file name, then press Enter.

3. CSEntry will ask if you want to create a new file. Click Yes.
4. CSEntry will ask for your Operator ID. You may type in anything you like.

5. The first data entry form will appear with the cursor ready for you to begin entering data.

When you have completed this step the screen should look something like:

™ CSEntry (Application: MyEntry - Data: MyData.dat) — O *
File Meode Edit Mavigation View Options Help

=|E_F B 1 = ?

File |

...... ] < Adding Case>

MyDict identification | ., |

For Help, press F1 Mo Partials  |ADD Field = MYDICT_ID

Continue to the next step: Step 2: Add a Case.
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Step 2: Add a Case

(Exercise 4, Enter Data)
We will now type in the data for our first case (questionnaire). We will use a fictitious family of four.

1. Type 1then Enter tofill in the ID item. The next form will appear, showing the person roster.
2. Type 48 in the Age field. The cursor will move to the Sex field.

3. Type 3in the Sex field. CSEntry will tell you this value is out of range, because it is not in the value set for Sex you
created in your data dictionary.

4. With the OUT OF RANGE message still showing, type 1. The message will go away and the cursor will move to the
Marital status field.

5. Continue typing in data for the family as shown below.
Some CSEntry tips:

e You can move backward to the previous field using Shift+Tab, left arrow or up arrow.

e You can move forward to the next field using Enter, Tab, right arrow or down arrow.

You can change a field by simply typing a new number into it.

e You can erase a field using the space bar.

™ CSEntry (Application: MyEntry - Data: MyData.dat) — O X
Eile Meode Edit MNavigation Yiew Options Help

=|B_*F B 1= ?

File |

------ [ ] <Adding Case>
Age| Sex| Marital status

A O 551
I} o o =2 =) S =)
I o o S S (=)

For Help, press F1 Mo Partials  |ADD Field = AGE

Continue to the next step: Step 3: Finish Adding a Case.
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Step 3: Finish Adding a Case

(Exercise 4, Enter Data)
We will now tell the roster that we have finished entering people.

1. Hold down the Ctrl key.

2. Press the slash key / (on the numeric keypad). The next form will appear on the screen. If you have trouble finding this
key combination, which could be the case on some laptops, you can select Navigation -> End Group from the main
menu.

Next we will type in the household form and end the case.

1. Type 1inthe Type household field.
2. Type 1inthe Type roof field.

3. CSEntry will ask us to accept the case. At this point you can select No and go back and make changes to the data in
the case if you like. If you are satisfied that the data are correct, press Enter or select Yes.

4. CSEntry will now show the first form again, with the cursor ready for you to type in another case. We will now stop
adding cases. Click B on the toolbar, or press Esc or Ctrl+S, or select Mode -> Stop from the main menu.

When you have completed this step the screen should look something like:

™ CSEntry (Application: MyEntry - Data: MyData.dat) - O X
Eile Meode Edit MNavigation Yiew Options Help
= 8. B 7
File |
...... m] 1
<«Text File>> C:\CS5ProTutorial‘MyData.dat
Cases 1
For Help, press F1 Mo Partials

Continue to the next step: Step 4: Modify a Case.
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Step 4: Modify a Case

(Exercise 4, Enter Data)

Now we realize that the first person in the household is really 45-years-old and not 48 as we typed in. We will go back into
the data and change this value.

1. Click on & on the toolba r, or press Ctrl+M to enter Modify mode. You should see the first form, with the value 1
showing for MyDict identification.

2. Pressthe PgDn key to advance to the next form.

3. Type 45 in the Age field.

4. Press F12 to indicate that you have finished making your changes.

5. The screen will now look something like the picture below. CSEntry will ask you to accept the case, like it did in the
previous step. Select Yes.

6. CSEntry will save your changes and exit from Modify mode.

7. Close CSEntry by clicking on the X in the top right corner, or selecting File -> Exit from the main menu.

-
File Mede Edit Mavigation View Options Help
= BB 1 E e R
Fe |
...... 1 1
Age| Sex| Marital status
1
alla o]l [o] [1]
C5Pro Data Entry i—
| Accept this case? }-
RN No | ]
8, | L] L
ol | [ []
o[ ] [ []
For Help, press F1 Mo Partials  |MODIFY Field = SEX

This completes this exercise. Continue to the next exercise: Step 1: Create a Tabulation Application.
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Exercise 5: Tabulate Data

Step 1: Create a Tabulation Application

(Exercise 5, Tabulate Data)
In this exercise we will perform simple cross tabulations of the data you entered in the previous exercise.

If you still have your data entry application open from previous exercises, close it now. Select File -> Close from the main
menu. CSPro may prompt you to save changes. Select Yes.

We will now create a cross tabulation application using the Wizard, as we did previously.

Mew >

Application l Cither ]

Application Type:

A C5SPro applications process data
. Data Ent licat
— a Entry Application from surveys and censuses. All the

files necessary for an application
‘,. CAPI Data Entry Application | can be specfied when the
application is created.

/ Batch Edit Application

Choose Data Entry Application to
keery from paper; select CAF| Data
Entry Application to conduct a
computer assisted personal
interview using a phone, tablet, or
laptop.

] | Cancel Help

1. Select File -> New from the main menu, or click 3 on the toolbar.

2. Select Tabulation Application and press OK.

3. Inthe file open dialog box, enter MyTab as the file name for the application.

4. Make sure you are located in the folder you created for these exercises (C:\CSProTutorial).
5. Press Save.

6. The next screen will ask you to select the Input Dictionary.

7. Change the name to C:\CSProTutorial\MyDict.dcf.

8. Press OK.

You are now ready to begin designing your tabulation.

When you have completed this step the screen should look something like:
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CSPro - [MyTab.ts] — O >
File Edit View Tools Window Help - &

El
D% 0SS ¥ 8 X & * ?

Eﬁ My Dict Table 1
El!!. MyDict questionnaire
-2 (Id kems)

i - mm Person record

: [+]-—mm Housing record
I -4 MyTab - Working Storage Dictionary

For Help, press F1 Relative Positions MU

Continue to the next step: Step 2: Select Items to Tabulate.

Step 2: Select Items to Tabulate

(Exercise 5, Tabulate Data)

We will create a tabulation of Age by Sex. Age will appear as the rows and Sex as the columns.

1. Click on the + next to Person record to make sure its items are showing on the tree.

2. Drag and drop Age from the tree to the left side of the table. (Click on Age and hold the mouse button down while
you move the mouse to the side of the table then release the mouse button.) The drop point should be in the white
space next to one of the gray boxes along the side.

3. Drag and drop Sex from the tree to the top of the table. (Click on Sex and hold the mouse button down while you
move the mouse to the top of the table then release the mouse button.) The drop point should be in the white space
just under one of the gray boxes along the top.

Tips for creating tabulations:

e The item you drag from the dictionary tree will become either a row item or a column item depending on where you
drop it. Imagine a diagonal line from the top left to the bottom right of the table. An item dropped on the left/under
that line becomes a row item. An item dropped on the right/above that line becomes a column item.

e You canremove an item from the table by clicking on any of its associated labels then dragging and dropping it back
to the dictionary tree.

When you have completed this step the screen should look something like:
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& C5Pro - [MyTab.ds] — O ot
File Edit View Tools Window Help - &
D& 0SS & B X i o * 7
-4 WyDict Table 1. Age by Sex
El!!. MyDict questionnaire Age Sex
B2 {id fems) J Total| Male|  Female
El-—mm Person record Total
..M Age
..... | Sex 0-9
. M Martial status 10 -19
(- == Housing record 20 - 29
(-4 MyTab - Working Storage Dictionary 30 - 39
40 - 49
50 -59
60 - 69
0-79
a0 - 89
90 -99
For Help, press F1 Relative Positions MU

Continue to the next step: Step 3: Run the Tabulation.

Step 3: Run the Tabulation

(Exercise 5, Tabulate Data)
We are now ready to run the tabulation. We will use the data file you created in the previous exercise.

1. Run the tabulation by clicking on ;] on the toolbar, or pressing Ctrl+R. If CSPro prompts you to save the changes,
click on Yes.

2. CSPro will ask you for the data file(s) to tabulate. Select MyData.dat. Make sure the dialog box is set to the folder you
created for these exercises, C:\CSProTutorial.

3. The tabulated numbers will now appear in the table. That's all there is to it!

When you have completed this step the screen should look something like:
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& CSPro - [MyTab.xts] — O e
Eile Edit View Tools Window Help

D= O0RE E .- X & B a5 0 »

| | |
=& MyTab Table 1. Age by Sex
H-E Table 1. Age by Sex —Age Sex

Total | Male | Female

~ |Total 4 3 1

~0-9 1 1 -

- 10-19 1 1 -

- 20-29 - - -

- 130-39 - - -

~40-43 2 1 1

~ |50-59 - - -

~ |60-69 - - -

- |T0-79 - - -

~|80-89 - - -

~ 190-99 - - -

¢ lables |

For Help, press F1 |F‘.elati1.re Positions | | | |

This completes this exercise. Continue to the next exercise: Step 1: Add Percents.
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Exercise 6: Modify the Table

Step 1: Add Percents

(Exercise 6, Modify the Table)

In this exercise we will modify the table you created in the previous exercise. We will begin by adding percents to the
columns next to the values for the Sex variable.

Tally Attributes (Sex) X

Available: Selected:

Counts Total

Total Total Percent{Same as Percents)
Counts

Total Percent Percents(Column; Interleaved)
Mean

Median

Mode

Standard Deviation
Variance

M-tiles

Minirmum

Maximum
Proportion

e
_w |
T
E=T

QK Cancel | Reset | Help

1. Right-click on the word Sex on the table, just above the word Male.
2. Select Tally Attributes (Sex) from the right-click menu.

3. Inthe list on the left of the dialog box marked Available, click on Percents and then click the Add --> button. You
should now see Percents listed in the list on right of the dialog box marked Selected.

4. Click OK. You should see three new columns on the table for the percents.

5. Run the tabulation by clicking g on the toolbar, or pressing Ctrl+R. When CSPro prompts you to save the changes,
click on Yes.

6. Select MyData.dat as the data file to tabulate, asin the previous exercise.

When you have completed this step you should see a table that looks something like:
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For Help, press F1

& C5Pro - [MyTab.ds] — O ot
File Edit View Tools Window Help - &
DEEHEE O&S & B8 X i B * ?
Table 1. Age by Sex
Age Sex
Tutal| F'ert:ent| Male| F'ert:ent| Female|

Tatal 4 100.0 3 100.0 1

0-9 2510 1 333

10 - 19 2510 1 333

20-29 - -

30-39 - -

40 -49 2 50.0 1 333 1

50 - 59 - -

60 - 69 - -

T0-79 - -

80 - 89 - -

90 - 99 - -

Relative Positions

Continue to the next step: Step 2: Add a Universe.

Step 2: Add a Universe

(Exercise 6, Modify the Table)

We will now add a universe to our table. A universe is a filter, or a way of restricting the table to a subset of the data records
that meet a certain condition. In this step we will run the table for married people.
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Tally Attributes (Table)

—Tally

Table (Subtables): IEnﬁre Table

Unit Talied: |Default (PERSON_RECORD) -l

Value Tallied: I

Weight: I

=

ModiFy All Subtables |

apply to all Tables |

Universe: MARITAL STATUS = 1

Edit apply ko All Tab

Tab Logic:

Edit

—PostCalc

Logic:

Edit

—Spedal values
[~ Use custom spedal values: [T motappl (blank) values
[T Missing values

[T Defaulk firealid) walues
™ Undefined walues (nat in value set)

—Area

Lowest Break Level: ﬂ

QK I Cancel |

Help

1. Right-click anywhere on the table.

2. Select Tally Attributes (Table) from the right-click menu.

3. Inthe section of the dialog box marked Universe, type MARITAL STATUS = 1. Be sure to type this correctly,

otherwise you may see the message "Invalid Universe Syntax."

4. Click OK.

5. Run the tabulation by clicking - ] on the toolbar, or pressing Ctrl+R. When CSPro prompts you to save the changes,

click on Yes.

6. Select MyData.dat as the data file to tabulate, asin the previous exercise.

When you have completed this step you should see a table that looks somet

hing like the following. Notice that the counts

are lower than in the previous step because we are not counting unmarried people.
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CSPro - [MyTab.ts] — O >
E

ile Edit View Tools Window Help - &

&
DeEdB ORS ¥ Bg X s @ * ?

Table 1. Age by Sex

5
Age EX

Tutal| F'ert:ent| Male| F'ert:ent| Female| Percent
Total 2 100.0 1 100.0 1 100.0
0-9 - - - -
10 - 19 - - - -
20-29 - - - -
30-39 - - - - - -
40-49 2 100.0 1 100.0 1 100.0
50 - 59 - - - -
60 - 69 - - - -
70-79 - - - -
80 - 89 - - - -
90 - 99 - - - -

For Help, press F1 MU

Continue to the next step: Step 3: Change the Title Font.

Step 3: Change the Title Font

(Exercise 6, Modify the Table)

CSPro gives you great control over the format of your tables. As an example, in this step we will change the font of our
table's title to make it bigger.
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Format (Title)

—Status
™ Hide [ Custom Text
[T Hide when &l Cells in Row are Zero

—Font and Color

Arial, 16 point, bold Change |
Text Color Fill Color D

—Indent
[T Use default indentation

Left IU in.  Right IU in.

— Alignment
Horizontal IDEfault {Left) LI
Vertical IDEfauIt (Top) LI

>
—Lines
Left IDefauIt (MNane) ;I
Right IDefauIt (Maone) ;I
Top IDefault (Mone) ;I
Bottom IDefault {Mone) ;I

— Associated Cells
[T Extend Font inko Cells

[T Extend Lines into Cells

[T Extend Text Color inka Cells
[T Extend Fill Color inko Cells
[T Extend Indentation into Cells
™ Span fields

Decimal places: I

8.4 I Reset

Cancel | Help |

1. Right-click on the title Table 1. Age by Sex at the top of the table.

2. Select Format (Title) from the right-click menu.

3. Inthe section of the dialog box marked Font and Color click on the Change button.

4. Inthe Font dialog box that appears, change the Size from 12 to 16.

5. Click OK to close the Font dialog box.

6. Click OK to close the Format (Title) dialog box.

When you have completed this step you should see that the title is now larger.

This completes this exercise. Continue to the next exercise: Step 1: Write Logic for the Edit.
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Exercise 7: Add Edits to the
Data Entry Application

Step 1: Write Logic for the Edit

(Exercise 7, Add Edits to the Data Entry Application)

We will now return to the data entry application. We will introduce a check to make sure that married people are at least
12-years-old. In our data entry application, we will perform this check immediately after the keyer enters the marital status.

If you still have your cross tabulation application open from previous exercises, close it now. Select File -> Close from the
main menu. CSPro may prompt you to save changes. Select Yes.

']
1. Open the data entry application we created earlier. Click on [£# on the toolbar, or select File -> Open from the main
menu. Click on the application name, MyEntry.ent, and click Open.

2. Get ready to write logic by clicking 2= on the toolba r, or pressing Ctrl+L or selecting View -> Logic from the main
menu.

3. Press Ctrl+T to show names instead of labels in the forms tree.

4. Click on the + next to PERSON_RECORD_FORM then click on the + next to PERSON_RECORDO00O then click on
MARITAL_STATUS. The frame on the right hand side of the screen should show PROC MARITAL_STATUS at the
top.

5. Note that PROC is short for procedure. We put our logic in the procedure for MARITAL_STATUS because we want it
to execute immediately after the operator keys this field.

6. Type in the logic code exactly as you see below.

PROC MARITAL_STATUS
if MARITAL_STATUS = 1 and AGE < 12 then

errmsg("Too young to be married");
endif;
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&2 C5Pro - [MyEntry.fmf] — O e
ﬂ File Edit View Options Align CAPl Opticns Tools Window Help - &
Dl £ § 'y SR * 7
PROC MARITAL STATUS
E@ MYDICT_FF if MARTTAL STATUS = 1 and AGE < 12 then
!!' MYDICT_QUEST errm3g("Too youngy to be married"):
L—_IE_l IDS0_FORM endif s
@ MYDICT_ID ’ !
=-00 PERSON_RECORD_FORM
= - PERSON_RECORDOOO
..... m AGE
- MARITAL_STATUS
-0 HOUSING_RECORD_FORM
b | > _[}F roms | M4 » H\Eumpilerﬂutput},‘ Message § Feference [ | 4 | hl—
For Help, press F1 LnQ, Col 0

Continue to the next step: Step 2: Compile the Logic.

Step 2: Compile the Logic

(Exercise 7, Add Edits to the Data Entry Application)

You have typed logic in the CSPro language. Like all procedural languages, the system must check to make sure that there
are no syntax errors. This is called compiling.

1. Click on MYDICT_FF in the forms tree to show all the CSPro logic.
2. Compile the logic by clicking # on the toolbar, or pressing Ctrl+K or selecting File -> Compile from the main menu.
3. If you typed the logic correctly, you will see Compile Successful in the Compiler Output window under the logic.

4. If you see a dialog box that says Compile Failed, you have typed something incorrectly. A red circle will appear in the
margin indicating the approximate location of the error. The Compiler Output tab at the bottom of the screen will
show you an error message to help you determine the error. Check very carefully to make sure you typed in exactly
what was shown in the previous step.

When you have completed this step the screen should look something like:
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& CSPro7.0 (beta) - [MyEntry.frnf]

DEE X §

ﬁ‘FiIE Edit View Options Align CAPlI Options Tools Window Help

4

EER=AE ?

- MYDICT_FF
=Yg, MYDICT_QUEST
-0 IDS0_FORM
L..e MYDICT_ID
=00 PERSON_RECORD_FORM

l"’ MARITAL_STATUS
-0 HOUSING_RECORD_FORM

—

{Application "MYENTRY' logic file generated by CS5Prc

FROC GLOCBLL
FPROC MYDICT FF

PROC MARITAL STATUS

if MARTTAL. STATUS = 1 and AGE < 12 then
errmeg{"Too yvoung to be married™);
endif;

_H\_'_FHEET'@_DTC[S I-'_-|_|J Forms |

For Help, press F1

Compile Successful

M AP H\Eumpiler I]utput,l,[ Meszage }I, Reference JIJ |4

Ln0 Col0

Continue to the next step: Step 3: Test the Edit.

Step 3: Test the Edit

(Exercise 7, Add Edits to the Data Entry Application)

We are now ready to run the data application and make sure our logic is working properly.

1. Run CSEntry by clicking H on the toolbar, or pressing Ctrl+R.

2. CSPro will ask you to save the changes. Click Yes.

3. CSEntry will ask you to select a data file. Type MyData.dat for the file name, if it is not already there, then press OK.

4. Type in any Operator ID.

5. Click on E+- on the toolbar, or press Ctrl+A to enter Add mode. The first form will appear with the cursor on MyDict

identification.

6. Type 2 and then Enter to fill in the ID item. The next form will appear, showing the person roster.

7. Type 10 in the Age field.
8. Type 1inthe Sex field.

9. Type 1in the Marital status field.

Your error message should appear on the screen as shown below.
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W CSEntry (Application: MyEntry - Data: MyData.dat) — O X
File Mode Edit Navigation View Options Help
=B B 1= 7
Fle |
-~ 1
.| <Adding Case> Age| Sex| Marital status
1
2 ) [ []
3L | [ L]
4l ) [ []
5) | L[] L]
6L, 1) [ []
7L ] [ L]
gl [ []
9 |_,__| D D Too young to be married
w| ] [] [] Press F8 to clear
For Help, press F1 Mo Partials  |ADD Field = MARITAL_STATUS

Continue to the next step: Step 4: Complete the Case.

Step 4: Complete the Case

(Exercise 7, Add Edits to the Data Entry Application)

We will finish entering data for the second case, including the error condition, so that we will be able to test that condition in
the following exercise.

1. Press F8 to clear the message.

2. Hold down the Ctrl key and press the slash key / on the numeric keypad. The next form will appear on the screen.

3. Type 1inthe Type household field.

4. Type 1inthe Type roof field.

5. CSEntry will ask us to accept the case. Select Yes.

6. Click B on the toolbar, or press Esc or Ctrl+S, or select Mode -> Stop from the main menu.

7. Close CSEntry by clicking on the X in the top right corner, or selecting File -> Exit from the main menu.

This completes this exercise. Continue to the next exercise: Step 1: Create a Batch Application.
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Exercise 8: Run a Batch
Application

Step 1: Create a Batch Application

(Exercise 8, Run a Batch Application)

In the previous exercise we wrote logic to perform an edit interactively, i.e. at the time of data entry. In this exercise we will
apply the same logic in a batch application, i.e. after data entry. Our logic will check the data and produce a report telling us
about any errors.

If you still have your data entry application open from previous exercises, close it now. Select File -> Close from the main
menu. CSPro may prompt you to save changes. Select Yes.

We will now create a batch application using the Wizard, as we did previously.

Mew >

Application l Cther ]

Application Type:

-' Data Ent licati C5Pro applications process data
—— a Entry Application from surveys and censuses. All the

files necessary for an application
‘. CAPI Data Entry Application | can be specfied when the

application is created.

Choose Data Entry Application to
key from paper; select CAP| Data
Entry Application to conduct a
computer assisted personal
interview using a phone, tablet, or
|aptop.

e Tabulation Application

QK | Cancel Help

1. Select File -> New from the main menu, or click [ on the toolbar.

2. Select Batch Edit Application and press OK.

3. Inthe file open dialog box, enter MyBatch as the file name for the application.

4. Make sure you are located in the folder you created for these exercises (C:\CSProTutorial).
5. Press Save.

6. The next screen will ask you to select the Input Dictionary.

7. Change the name to C:\CSProTutorial\MyDict.dcf.

8. Press OK.

You are now ready to begin designing your batch edit application.
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When you have completed this step the screen should look something like:

& C5Pro - [MyBatch.ord)] — O x
File Edit Yiew Options Toels Window Help - &

D & « o B *» ?
{Application '"MYBATCH' logic file generated by CSPrc

FROC GLOBAL

MYDICT_FF

'!.!_ MYDICT_QUEST PROC MYDICT FF
=-@ IDS0_EDT Bl

w0 PERSON_RECORD_EDT
-8 HOUSING_RECORD_EDT

H A P H\Eumpiler I]utputJJ,[ Mezzage }, Reference J.J |4 | Irl—

For Help, press Fl Dicticnary Order MUM

Continue to the next step: Step 2: Write Logic and Compile.

Step 2: Write Logic and Compile

(Exercise 8, Run a Batch Application)
We will write the same logic we used in the previous exercise.

e Press Ctrl+T to show names instead of labels in the edits tree.

e Click on the + next to PERSON_RECORD_EDT then click on MARITAL_STATUS. The frame on the right hand side of the
screen should show PROC MARITAL_STATUS at the top.

e Type in the logic exactly as you see below.

e Note that we used $ in place of MARITAL_STATUS. This is the same thing because the logic is inside the procedure for
MARITAL_STATUS. In the CSPro language, $ is a short way of saying "this item."

e Compile the logic by clicking & on the toolbar, or pressing Ctrl+K or selecting File -> Compile from the main menu.
e Correct any errors until you see Compile Successful.
PROC MARITAL_STATUS

if $ = 1 and AGE < 12 then

errmsg("Too young to be married");
endif;
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& CSPro - [MyBatch.ord)] - O o
File Edit View Options Tools Window Help - &
DEE g o R E S e |
] PRCC MARTTAT. STATUS
=3 MYDICT_FF if § = 1 and AGE < 12 then
El!!. MYDICT_QUEST errm=g({"Too yvoungy to be married"™):
-l IDSO_EDT endif:
E|i' PERSOMN_RECORD_EDT
-0 SEX
; - MARITAL_STATUS
-0 HOUSING_RECORD_EDT
Hl . | » | H['\,Eumpiler Output I-I,[ Message :i, Reference f | 1/ |L|-
For Help, press F1 | | | | |

Continue to the next step: Step 3: Run the Batch Application.

Step 3: Run the Batch Application

(Exercise 8, Run a Batch Application)

Your batch application is now ready to run. CSBatch is the name of the program that runs this application. We will use the
data file you created in the previous exercise.

1. Run CSBatch by clicking ¥¥ on the toolba r, or pressing Ctrl+R.

2. CSPro will ask you to save the changes. Click Yes.

3. CSBatch will ask for some data file names. Click in the empty box next to Input Data File and type in MyData.dat and
click OK.
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MyBatch
Crata File Mame Source Type
Input Crata File C:ACSProTutorialy Myl ata, dat | Tent -
<Output Filex | None -
<Listing Filex b uB atch, bt
Cancel Help
CSBatch will now run your program.
Continue to the next step: Step 4: Examine the Output Report.
Step 4: Examine the Output Report
(Exercise 8, Run a Batch Application)
The output report will appear in the CSPro Text Viewer. It will look something like:
Application C:\CSProTutorial\MyBatch.bch
Type BATCH
Input Data <<Text File>> C:\CSProTutorial\MyData.dat
<Output> <<Empty>>
Date Jun 5, 2020
Start Time 07:11:00
End Time 07:11:00
CSPRO Process Summary
R et e +
| 7 Records Read ( 100% of input file)
| 0 Ignored ( @ unknown, 0 erased) |
| 1 Messages ( 1U, 0 W, 0 E) |
T domm e domm e Fommm e +
| Level | 1Input Case | Bad Struct | Level Post |
dommmmmm - R R oo +
I 1 2| o | 2 |
e it it Fommm e +
Process Messages
*** Case [ 2] has 1 messages (0 E / @ W / 1U)
U -9 Too young to be married
User unnumbered messages:
Line Freq Pct. Message text Denom
9 1 - Too young to be married -

CSPRO Executor Normal End
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The first several lines show file names and the date and time of the run.
CSPro Process Summary

o The first line tells us that the data file had seven records.
e The second line tells us that there were no problems with the structure of the data file.

e The third line tells us that one user message was triggered by our logic. The system did not issue any warning or
error messages.

e The last line tells us that our data file has two cases in it.
Process Messages

This section shows messages by case by case. In our example we only triggered one message, so only one case is shown. Case
[ 2] shows us the case ID; in this example the second case has the error.

User Unnumbered Messages

This section shows a summary by message, Since we have only errmsg command in our logic, there is only one line. The
number 9 under Line tells us the line number of the errmsg command in our logic. The number 1 under Freq tells us that
this message was only triggered once for the data file.

Conclusion
When you have finished examining the report, close Text Viewer by pressing Esc or selecting File -> Exit from the main menu.

Congratulations! You have completed the CSPro tutorial. We hope you are now ready to try creating and running your own
applications. Please refer to our User's Guides for more details. You can access them from CSPro simply by selecting Help ->
Help Topics from the main menu of any CSPro module.
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